Wishnewski
02.03.2023 13:34

Запишите на языке Паскаль программы решения задач № 25-30 из & 2.4. Используйте оператор while.
25) Напишите алгоритм, под управлением которого Робот обойдет прямоугольную область, обнесённую стеной, по периметру и закрасит угловые клетки. Размеры области неизвестны.
26) Запас рыбы в пруду оценен в А тонн. Ежегодный прирост рыбы составляет 15%. Ежегодный план отлова — В тонн. Наименьший запас рыбы составляет С тонн. (Запас ниже С тонн уже не восстанавливается.) Составьте программу для подсчёта количества лет, в течение которых можно выдерживать заданный план.
27) Дана последовательность 5, 9, 13, 17, … . Составьте программу для определения числа слагаемых, сумма которых равна 324.
28) Составьте программу для определения количества цифр в записи произвольного натурального числа.
29) Сумма 10000 рублей положена в сберегательный банк, при этом прирост составляет 5% годовых. Составьте программу, определяющую, через какой промежуток времени первоначальная сумма увеличиться в 2 раза.
30) Одноклеточная амёба каждые 3 часа делится на 2 клетки. Составьте алгоритм вычисления времени, через которое будет X амёб.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Регина2411
02.04.2022 03:03

N= 2^{i}

"N" - мощность алфавита.

информационный вес символа алфавита "i"

#1. N=2 в степени i

Так как N=32, отсюда следует, что i=5 битам.

#2. По аналогии выше. Только теперь N=8. А 8 - это 2 в степени 3.

то есть i=3. 3 бита.

#3. 64 символа. (смотреть задачу 1). 2 в 6 степени.

#4. Определим, сколько бит занимает все сообщение.

1/512 Мбайт = 1024/512 = 2 Кбайт. (1 Мбайт = 1024 Кбайт);

2 Кбайт = 2 * 1024 = 2048 байт (1 Кбайт = 1024 байт);

2048 байт = 2048 * 8 = 16384 бит.

Текст состоит из 2048 символов ⇒ занимает 16384 бит ⇒ один символ занимает 16384 : 2048 = 8 бит = 1 байт.

Если для хранения 1 символа алфавита используют 8 бит, согласно формуле (смотреть выше) 2 ^ 8 = 256 символов.

ответ: размер алфавита - 256 символов.

0,0(0 оценок)
Ответ:
NJR228337
11.09.2020 14:57
Const   N = 10;   
var   a, S1, S2: Integer;   
i, Q1, Q2: Byte;   
begin   
S1 := 0; Q1 := 0;   
S2 := 0; Q2 := 0;  
writeln('Введите ', N, ' чисел:');   
for i := 1 to N do 
begin     
read(a);     
if a < 0 then 
begin      
S1 := S1 + a;       
inc(Q1)     
end;     
if a > 0 then 
begin       
S2 := S2 + a;       
inc(Q2)     
end;   
end;   
writeln;   
if Q1 > 0 then 
begin     
writeln('Сумма отрицательных чисел: ', S1);     
writeln('Количество отрицательных: ', Q1)   
end   
else 
writeln('Отрицательных нет');   
if Q2 > 0 then
begin     
writeln('Сумма положительных чисел: ', S2);     
writeln('Количество положительных: ', Q2)   
end   
else 
writeln('Положительных нет') 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота