alapova1
12.02.2023 10:07

1. Составить программу нахождения значения функции у:

у=3х+1, если х>0, у=х-5, если х<0.

2. Составить программу решения квадратного уравнения. (Пояснение: все квадратные уравнения отличаются коэффициентами а, в, с, которые участвуют в нахождении корней уравнения, при этом надо помнить, чтобы квадратное уравнение имело корни должно выполняться определенное условие.

3. Составить программу, определяющую является ли треугольник равнобедренным, если известны его стороны.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ukrainskayaa
26.08.2022 02:23
Самый простой вариант - подсчитать сумму четных и нечётных через цикл, в котором берём остатки от деления. Можно начать с конца и соответственно начать подсчитывать сумму только от первого числа с конца не равного 0. Подсчитываем через целочисленное деление на круглое число и нахождение остатка при деление на один. Данные, чередуя, прибавляем к разным переменным(пусть будут x1 и x2). Затем проверяем остаток от деления одной переменной на другую. Если 0 - "Yes", иначе - "No" For i=5 downto 1 do If i Mod 2 = 1 then a:= a+n div (10^(i-1)) mod 10 Else B=B+ div (10^(i-1)) mod 10;
0,0(0 оценок)
Ответ:
zalinairina9
08.05.2023 18:54

Объяснение:

def amount(a, b):

   if b > 0:

       a += 1

       b -= 1

       return summ(a, b)

   else:

       return a

n = int(input())

m = int(input())

print(summ(m, n))

Сначала проверяется условие b > 0. Это базовый случай, то есть случай, когда рекурсия заканчивается. Потом идёт присваивание первому числу единицы, а из b она вычитается. Прибавление единицы числу a будет ровно b раз, то есть к числу а прибавится значение числа b. И когда уже b равно нулю, то происходит выход из рекурсии, и функция возвращает число a, то есть сумму чисел a и b.

Програмка не работает с отрицательными числами, мне лень думать :3

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота