vitek03
19.08.2022 02:24

Написать программу, которая вычисляет сумму покупки трех видов товаров: тетрадей, ручек и
карандашей. Стоимость тетради – 20 руб, карандаша – 3 руб, ручки – 5 руб. Стоимость покупки
зависит от количества проданного товара.
Предлагаемый вид экрана.
Количество тетрадей: 4
Количество карандашей: 5
Количество ручек: 5
Стоимость покупки: 120 руб

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Iasia198
30.06.2021 14:18
Растровое изображение представляет из себя:
✔ мозаику из очень мелких элементов — пикселей;
сочетание примитивов (это про векторное изображение);
палитру цветов.

Растровое графическое изображение формируется из:
линий
✔ пикселей
графических примитивов (это про векторное изображение)

В векторной графике изображения строятся из:
пикселей (это про растровую графику);
✔ примитивов;
рисунков.

Эффективно представляет изображения фотографического качества:
векторная графика;
✔ растровая графика.

Относительно небольшой объём памяти занимают:
✔ векторные рисунки; (это как правило верно. Но если пытаться делать изображения фотографического качества в векторной графике, файлы будут получаться огромными)
растровые изображения.

Могут быть легко масштабированы без потери качества:
✔ векторные рисунки;
растровые изображения.

Растровое графическое изображение получается:
✔ в процессе сканирования (в остальных случаях - векторная)
при работе с системами компьютерного черчения
при создании рисунка в MS Word

Какой тип графического изображения вы будете использовать при редактировании цифровой фотографии?
✔ растровое изображение
векторное изображение

Что можно отнести к достоинствам растровой графики по сравнению с векторной?
Малый объём графических файлов. (это про векторную)
✔ Фотографическое качество изображения.
Возможность просмотра изображения на экране графического дисплея. (это верно для любой компьютерной графики)
Возможность масштабирования изображения без изменения его качества. (это про векторную)

Файлы, с какой графикой имеют наибольший размер?
✔ Растровой.
Векторной.
Трёхмерной. (обычно простенькая трехмерная графика составляется из примитивов и имеет небольшой размер. Но опять-таки, если ставить целью добиться максимальной естественности изображения, то здесь будет максимальный размер) 

Изображения, какой графики состоят из массива точек (пикселей)?
✔ Растровой.
Векторной
Трёхмерной

Для хранения растрового изображения размером 64 на 64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения?
Всего пикселей 64 * 64 = 2^12, на них отводится 512 байт = 2^9 байт = 2^12 бит. Тогда на 1 пиксель отводится всего 1 бит, и в палитре не больше 2^1 = 2 цветов.

В процессе преобразования растрового графического файла количество цветов уменьшилось с 512 до 8. Во сколько раз уменьшился информационный объем файла?
512 = 2^9, 8 = 2^3. В первом случае на 1 пиксель отводится 9 бит, во втором - 3 бита. Размер уменьшился в 3 раза.
0,0(0 оценок)
Ответ:
Lirki
13.05.2020 11:26
1)
program chik;
var a:array[1..100]of integer;
i,s:integer;
begin
for i:=1 to 11 do
begin
read(a[i]);
end;
s:=0;
for i:=1 to 11 do
begin
if(a[i] mod 5=0)then s:=s+a[i];
end;
write(s);
end.
 2)
program chik2;
var a:array[1..100]of integer;
i,s:integer;
begin
s:=0;
for i:=1 to 11 do
begin
read(a[i]);
end;
s:=0;
for i:=1 to 11 do
begin
if(a[i] mod 2=1)then s:=s+1];
end;
write(s);
end.
3)
program chik3;
var a:array[1..1000]of integer;
i:integer;
begin
for i:=1 to 9 do
begin
read(a[i]);
end;
for i:=1 to 9 do
begin
if(a[i] mod 2=0)then write(a[i],' ');
end;
end. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота