Егор111ив
10.02.2022 03:23

с информатикой
Практическая работа

Линейные программы. Арифметические выражения

Задание 1. Даны x, y, z. Написать программу для вычисления a

hello_html_266d9dc3.gif

Этапы выполнения задания

I Определение исходных данных: переменные x, y, z.

II Определение результатов: переменная a.

III Алгоритм решения задачи.

1 Ввод исходных данных

2 Вычисление значения выражения

3 Вывод результата.

IV Описание переменных:

Все переменные, определенные для решения задачи, имеют тип real. (Переменные x, y, z могут быть и целого типа, а переменная а только вещественного типа, поскольку в выражении используется операция деления.)

V Программа:

program Prim_1

Var x,y,z,a: real;

Begin

Write(‘введите значение x=’);

Readln(x);

Write(‘введите значение y=’);

Readln(y);

Write(‘введите значение z=’);

Readln(z);

a:=(2*x+3*y-z)/(3+2*x);

Writeln(‘a=’,a:7:3);

End.

VI Тестирование программы:

1. Запустите программу и введите значения

x=3

y=2

z=0

Проверьте, результат должен быть следующим:

a= 1.333

Проверить правильность вычислений можно на калькуляторе.

2. Заполните таблицу

x
y

z

a

1.

2

-5

1

2.

2.362

4.258

-7.458

3.

-1.2358

-4.554

5.562

3. Подберите такие значения x, y, z, чтобы значение а= 2.000

4. Что изменится и почему, если в программе заменить команду Writeln(‘a=’,a:7:3); на команду Writeln(a);?

5. Как распечатать только целую часть результата?

Примечание. Тип real предназначен для переменных вещественного типа. Переменные данного типа выводятся на экран монитора с большим дробным хвостом. Во избежание этого можно указать количество цифр выводимых вообще и после запятой (дробной части). Например, Writeln(‘a=’,a:5:2) - первая цифра 5 обозначает количество мест выделенных для цифр всего числа, вторая 2 - цифры дробной части. Точка тоже захватывается в количество мест для всего числа (т.е. в 5, в данном случае).

Задание 2. Даны x, y, z. Написать программу для вычисления b.

hello_html_3bacba08.gif

Тестирование программы:

1. Запустите программу и введите значения

x=9

y=-7

Проверьте, результат должен быть следующим:

a= 1.000

Проверить правильность вычислений можно на калькуляторе.

2. Заполните таблицу:

x

y

b

1

16

-5

2

2.362

4.258

3

-1.2358

-4.554

Задание 3. Составить программу вычисления значения выражения:

hello_html_m14161d4a.png

Заполните таблицу:

a

b

c

y

1

2,23

4,48

-2,5

2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
REIIKA
20.01.2022 08:39

Текстовый редактор предназначен именно для редактирования текста, четкого выставления знаков, например написания кода программ, просмотра файлов данных и т.п. Например заменить русской "у" латинское "y" будет считаться ошибкой

Текстовый процессор предназначен для создания и редактирования документов которые не предназначены для чтенья компьютером, но человеком. Когда внешний вид важнее реально содержащихся знаков ( допустимо заменить русской "у" латинское "y"). Так же там есть форматирование (шрифт, размер..), вставка обьектов типа рисунков и прочее внешнее оформление

0,0(0 оценок)
Ответ:
SemyaTanya
17.10.2022 01:43
В шестеричной системе алфавит состоит из цифр 0,1,...5.
Четырехразрядное число по условиям задания (1) и (2) имеет вид aabb,
где a=1,2,...5, b=0,1,...5.
В развернутой записи число имеет вид
a×6³+a×6²+b×6+b×1 = 6²×a(6+1)+b(6+1) = 7(36a+b)
При этом по условию (3) можно записать, что k² = 7(36a+b)
Чтобы число 7(36a+b) было полным квадратом, 36a+b должно быть кратно 7, а остаток от деления (36a+b) на 7 также должен быть полным квадратом.
Получаем, что 36a+b = 7m²
Минимальное значение 36a+b равно 36×1+0 = 36, следовательно m>2 (при m=2 получим 7×4=28, что меньше 36).
При m=3 получаем 36a+b = 63 и при a∈[1;5], b∉[0;5] решений нет.
При m=4 получаем 36a+b = 112 и находим a=3, b=4 - есть решение!
При m=5 получаем 36a+b = 175 и при a∈[1;5], b∉[0;5] решений нет.
При m=6 получаем 36a+b = 175 и получаем, что a=7, а это недопустимо. Дальше смысла проверять нет.
Итак, a=3, b=4, число 3344₆ = 7×(36×3+4) = 784₁₀ = 28²

ответ: 3344
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота