769429
15.09.2021 09:34

Жду вашего ответа осталось 2 часа
это всё в паскале

ЗАДАЧА 1. Напишите программу, которая формирует два одномерных массива из 100 случайных двузначных чисел каждый, находит суммы этих массивов и показывает их, и даёт ответ на во сумма какого массива наибольшая.

ЗАДАЧА 2. Написать программу, которая формирует три одномерных массива из 1000 случайных однозначных чисел каждый, находит суммы этих массивов и выводит их в поряд-

ке возрастания (наименьшая сумма вначале, наибольшая -вконце).

ЗАДАЧА 3. Написать программу, которая в одномерном масси-ве из 50 элементов находит все элементы больше значения 30

и считает их количество и сумму.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zubiks108642
03.01.2020 10:44
Первая программа:

Var a,b:integer;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
if a mod b = 0 then WriteLn(b,' - делитель ',a)
else WriteLn(b,' не является делителем ',a)
End.

Вторая программа:

Var
   a,b:real;
Begin
WriteLn('a и b - катеты прямоугольного треугольника');
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
WriteLn('S = ',a*b/2);
WriteLn('P = ',Sqrt(a*a+b*b)+a+b);
End.

Пример работы программы:

a и b - катеты прямоугольного треугольника
a = 3
b = 4
S = 6
P = 12

Примечание: программа не проверяет, существует ли треугольник и является ли он прямоугольным.

Третья программа:

Var
   a,b,c,D:real;
Begin
WriteLn('ax^2 +bx +c = 0');
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
D:=b*b-4*a*c;
if D < 0 then Write('Действительных корней нет')
else
   Begin
   WriteLn('x1 = ',(-b-Sqrt(D))/(2*a));
   WriteLn('x2 = ',(-b+Sqrt(D))/(2*a));
   End
End.

Четвёртая программа:

Var a,b,c:real;
Begin
Write('Введите три числа: ');ReadLn(a,b,c);
a:=Abs(a-c);
b:=Abs(b-c);
if a < b then WriteLn('Первое число ближе к третьему')
else if a > b then WriteLn('Второе число ближе к третьему')
     else WriteLn('Первое и второе число - одинаково близки к третьему')
End.

Пример работы программы:

Введите три числа: 1 2 3
Второе число ближе к третьему

Введите три числа: 1 1 3
Первое и второе число - одинаково близки к третьему

Введите три числа: 2 1 13
Первое число ближе к третьему
0,0(0 оценок)
Ответ:
kruglov428
03.01.2020 10:44

1)

 

var
a, b: integer;
begin
writeln('Введите a, b: '); readln(a, b);
if(b mod a = 0) then writeln('Является делителем')
else writeln('Не является делителем');
end.

 

2)

 

var
x, y, tmp: real;
begin
repeat
writeln('Введите x, y: '); readln(x, y);
until(x <> y);
if(x > y) then begin
tmp := y;
y := (x + y) / 2;
x := 2*(x * tmp);
writeln('Большее - X = ', x, ' Меньшее - Y = ', y);
end else begin
tmp := x;
x := (x + y) / 2;
y := 2*(tmp * y);
writeln('Большее - Y = ', y, ' Меньшее - X = ', x);
end;
end.

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота