LiNa20142014
31.05.2022 07:44

Напишите программу, в которой осуществляется ввод целых чисел до тех пор, пока не будет введена единица, и подсчет произведения положительных чисел, используя оператор repeat

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alinaaaa9
13.10.2020 12:04

var a,s: integer;

begin

s:=1;

repeat

write('Введите число: ');

readln(a);

if (a>0) then s:=s*a;

until a=1;

writeln('Произведение положительных чисел: ',s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота