eaglez91Aidana
04.09.2020 19:20

Напишите программу, которая определяет, попадает ли заданная точка в заданный прямоугольник. Стороны прямоугольника параллельны осям координат.
Исходные данные
Сначала с клавиатуры вводятся координаты левого верхнего угла прямоугольника, затем — правого нижнего, и в конце — координаты точки. Все координаты — целые числа, по модулю не превышающие 10000.
Результат
Программа должна выводить слово «YES», если точка находится внутри прямоугольника (границы считаются), и «NO» - в обратном случае.
Примеры
исходные данные результат
0 100 100 0 50 50
YES
0 100 100 0 0 0
YES
-100 100 100 -100 -500 900
NO
напишите на с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Нашли
14.11.2020 07:54
#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int n,sum=0; 
float y,k=0; 
cin >> n; 
int *mass = new int[n]; 
for (int i = 0;i < n;++i) 
{
cin >> mass[i]; 
} 
for (int i = 0;i < n;++i) 
{ 
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2); 
cout<<y;
sum+=mas[i]
}
} 
system("pause"); 
}

2)#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
0,0(0 оценок)
Ответ:
mitienko811
01.04.2023 06:02
Однажды Ослик не знал чем заняться. Все его друзья уехали кто куда: кто к бабушке в деревню, кто на море теплое, а кто вообще в лес, ягоды собирать. И стало ослику скучно. Но вот он увидел книгу с ноутбуком, и думает. Думает, что бы выбрать. Если выберет книгу, то быстро ее прочитает и это ему не так тем более она скучная. Вот ноутбук другое дело - там и поиграть можно, и с друзьями пообщаться, и спросить что-нибудь в интернете, да узнать что-нибудь новое. Вот ослик и выбрал ноутбук. И стал играть в нем в игры. 
Так несколько лет. Ослик все играл, да играл, а его друзья уже давно себе нашли работу, завели семью и все у них хорошо. А ослик так и потратил половину своей жизни, а в дальнейшем и всю жизнь, на игру. Так что не играйте в игры, а учитесь, развивайтесь и читайте книги! Не будьте осликами.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота