DAYN777DEBIL
04.03.2020 09:26

Составить программу, выполняющую вычисление: если число четное, то разделить его на 2, если нечетное - умножить на 2.

(Если число делится на 2 , то остаток равен, не делится - не равен 0, используйте функцию mod)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
санс
11.06.2022 15:44

каждый бит это один разряд то есть одна штука в переводе на русский но число может быть в слове бит от 0 до 1 если обращатся к математическому языку то есть два разных значения на русском языке бит можно выразить как да и нет или как истина и ложь или такой и сякой а на языке рисования можно взять кувалду ударить об стену и круг получившийся назвать ноликом или единичкой а чтото другое противоположным то есть если 0 назвали то это будет 1 хотя ему лишь различно выглядеть нужно а не выглядить противоположным. А вот слово разряд можно перевести как даже место в котором хранится в цифра, в разных системах счисления разная великость цифры например тут макс. 1 а там может быть и 9 и даже буквами рисуют означающие 15 например. Переводить слово разряд как место под цифру и бит как штуку это совсем вольный перевод мнение конечно будет менятся но пока что он удачен. Где то в непроверенных интернетах может это были комментарии пишут что цифра это то как число рисовать, число это сколько оно значит, ну а квадратик как в таблице умножения рисуют часто или яйчейка то есть место под цифру это разряд, не знаю можно ли им верить.

конкретно в ip адресе по 3 цифры перед точкой кажись в максимуме (но это крайне не точно) в десятичном представлении например адрес маршрутизатора 192.168.0.1 это значит нужно взять такое кол-во бит в двоичной системе чтобы из них число трёхциферное могло получится а это ln(192)/ln(2) далее округлить в большую до целого = 8 бит значит по 8 бит (по восемь циферек 1 или 0 в математическом языке) нужно отсчитать перевести их в десятичную систему и поставить точку ну соответственно раз точка ставится значит хоть и пишем (рисуем) цифры всё - равно это мы излагаемся на русском языке или математическом письменном языке так как в математике чистой или в информатике в устройстве точку не поставишь. Но это из неточного предположения что выше 256 цифры (макс 255 так как 0 тоже занимает место) не понадобится в ip адресе, а так 3 штуки влезет и 999 в десятичной системе и под него больше бит надо чем 8 шт., думаю под задачу и 256 хватит вполне, сколько понадобится под 999 считать через ln(999)/ln(2) далее округ. в больш. до целого, но в ip кажись от 0 до 255 макс хоть и не точно . А одиночный 0 или 1 можно написать как 000 или 001 тогда тоже 3 цифры а значение тоже выходит если вдруг такой приём конечно понадобится. Вопрос откуда начинать справа или слева у 10001001011100110001011001101010. Нарежем срава навсякий.

10001001.01110011.00010110.01101010

переводим через калькулятор окон xp: ответ

137.115.22.106

Объяснение:

0,0(0 оценок)
Ответ:
AnnaLyarskaya
31.10.2021 08:19

1.  

n=int(input())

k=float(input())

for i in range(1,n+1):

   print(i, "USD =", i*k, "UAH")

2.

i=input()

mas=[]

while i!="":

   mas.append(i)

   i=input()

mas.sort()

for z in mas:

   print(z)

3.

i=input()

mas=[]

while i:

   mas.append(int(i))

   i=input()  

slvr=["Monday","Tuesday","Wednesday","Thursday","Friday","Saturday","Sunday"]

for x in mas:

   if x>7 or 1>x:

       print("There is no such day of the week.")

   else:

       print(slvr[x-1])

4.

i=input()

mas=[]

while i:

   mas.append(int(i))

   i=input()

 

for x in mas:

   print(str(x)[-1] is "5")

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота