KuDiAnA2003
14.09.2022 10:17

НУЖНА Т-Т
Нужно составить программу в паскале.
Дан массив из 20 элементов,заполненный случайными числами от -15 до 30. Нужно найти номера максимального и минимального элементов этого массива.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vovalomov00
28.08.2020 13:20

1.

program z1;

const n=20;

var a:array [1..n] of integer;

i,maxi,mini:integer;

begin

maxi:=1;

mini:=1;

write('Массив А: ');

for i:=1 to n do

begin

a[i]:=random(46)-15;

if a[i] > a[maxi] then maxi:=i;

if a[i] < a[mini] then mini:=i;

write(a[i],' ')

end;

writeln;

writeln('Максимальный элемент a[',maxi,'] = ',a[maxi]);

writeln('Минимальный элемент a[',mini,'] = ',a[mini])

end.

2.

program z1;

const n=20;

var a:array [1..n] of integer;

i,max,min:integer;

begin

max:=-15;

min:=30;

write('Массив А: ');

for i:=1 to n do

begin

a[i]:=random(46)-15;

if a[i] > max then max:=a[i];

if a[i] < min then min:=a[i];

write(a[i],' ')

end;

writeln;

for i:=1 to n do

begin

if a[i]=max then writeln('Максимальный элемент a[',i,'] = ',a[i]);

if a[i]=min then writeln('Минимальный элемент a[',i,'] = ',a[i])

end

end.

Объяснение:

1. Не учитывает повтор элементов. Ищет первый максимальный и первый минимальный элементы.

2. Учитывает повтор элементов, но надо точно задавать max и min исходя из диапазона чисел.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота