Ivan700
19.03.2020 01:59

1)Составить программу.

Элементы двумерного массива – случайные числа, лежащие в диапазоне [0,40].

Найти минимальный элемент в каждом столбце массива.
2)Впишите в тексты программ операторы так, чтобы в результате были получены расположенные напротив них матрицы

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
MeilisS
01.11.2022 05:23
В общем случае, трассировка - один из отладки программ врукопашную: состояние программы контролируется на определённом отрезке времени её выполнения путём анализа значений переменных. трассировка в том или ином виде при отладке программ сложнее школьного дз практически неизбежна.
в простейшем случае, трассировка - вывод значений переменных на экран (например, в окно консоли) , либо расчёт их на бумажке для каждого шага.
в более продвинутом варианте используются точки останова, окно наблюдения, выполнение по шагам и, если есть, контекстный интерпретатор выражений.
есть также специальная "трассирующая консоль" - интерфейс вывода информации из программы в отладчик, если таковой присутствует.
почти любой современный отладчик показывает состояние програмm при её останове, что делает трассировку процессом легко доступным
0,0(0 оценок)
Ответ:
Вазген228
05.05.2020 01:59
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота