mikrob22
12.12.2022 13:40

Составить программу перевода заданного натурального числа N в систему счисления с основанием X.
Использовать в программе вс алгоритм «процедура» для перевода из десятичной системы счисления в любую другую.

Дополнительные условия:
1. Основная программа должна содержать ввод двух переменных (N и X – это глобальные параметры) и обращение к процедуре.
2. Имя процедуры любое на усмотрение разработчика программы.
3. Процедура должна оперировать с двумя входными данными (это локальные параметры), содержать основной алгоритм вычислений и вывод результата.

Задача №2
Составить программу вычисления площади четырехугольника произвольной формы с длинами сторон A, B, C, D и диагональю F. Использовать в программе вс алгоритм «функция» для вычисления площади одного треугольника.

Дополнительные условия:
1. Основная программа должна содержать ввод пяти переменных (A, B, C, D, F – глобальные параметры), обращение к функции (2 раза), вычисление общей площади четырехугольника и вывод результата.
2. Имя функции любое на усмотрение разработчика программы.
3. Функция должна оперировать с тремя входными данными (это локальные параметры) и содержать основной алгоритм вычисления площади треугольника по формуле Герона

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ariunkh
23.01.2023 12:43
Объект в программировании — некоторая сущность в виртуальном пространстве, обладающая определённым состоянием и поведением, имеющая заданные значения свойств (атрибутов) и операций над ними (методов) [1]. Как правило, при рассмотрении объектов выделяется то, что объекты принадлежат одному или нескольким классам, которые определяют поведение (являются моделью) объекта. Термины «экземпляр класса» и «объект» взаимозаменяемы. [2]

Объект, наряду с понятием класс, является важным понятием объектно-ориентированного подхода. Объекты обладают свойствами наследования, инкапсуляции и полиморфизма [1].
0,0(0 оценок)
Ответ:
9156612755tana
02.02.2022 12:48
/*
C++ compiler
gcc (Ubuntu 5.2.1-22ubuntu2) 5.2.1 20151010
Copyright (C) 2015 Free Software Foundation, Inc.
*/

#include <iostream>
#include <vector>
using namespace std;

int main()
{
    int count = 0;
    cout <<"Введите количество призывников: ";
    cin >>count;
    if (count>17) count=17;
    vector<int> tanks(count);
    for (unsigned i=0; i<tanks.size(); i++) cin >>tanks[i];
    int min=300, max=0;
    for (unsigned i=0; i<tanks.size(); i++)
    {
        if (min>tanks[i]) min=tanks[i];
        if (max<tanks[i]) max=tanks[i];
    }
    int cnt=0;
    for (unsigned i=0; i<tanks.size(); i++)
    {
        if ((tanks[i]!=min) and (tanks[i]!=max)) cnt++;
    }

    cout <<cnt <<endl;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота