89267989725
13.12.2020 03:49

Элементы массива ан вводятся с клавиатуры. Определите количество элементов, равных 3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Blackmamba06
05.04.2021 01:42
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
procedure MatPrint(a:array[,] of integer);
begin
  for var i:=0 to Length(a,0)-1 do begin
    for var j:=0 to Length(a,1)-1 do Write(a[i,j]:4);
    Writeln
    end
end;

procedure MatSwap(a:array[,] of integer);
begin
  for var i:=0 to Length(a,0)-1 do begin
    var jmin:=0;
    for var j:=1 to Length(a,1)-1 do
      if a[i,j]<a[i,jmin] then jmin:=j;
    Swap(a[i,jmin],a[i,Length(a,1)-1])
    end
end;

begin
  var a:=MatrixRandom(6,6,-99,99);
  Writeln('Исходный массив');
  MatPrint(a);
  MatSwap(a);
  Writeln('Результирующий массив');
  MatPrint(a)
end.

Тестовое решение:
Исходный массив
 -19  88 -17  20  36 -74
  40 -88  84  54  34 -86
 -13 -58  62 -55 -51  80
 -46 -35 -86 -57 -84 -29
  10 -55 -68 -49  12  78
  29 -86 -19  17 -79  61
Результирующий массив
 -19  88 -17  20  36 -74
  40 -86  84  54  34 -88
 -13  80  62 -55 -51 -58
 -46 -35 -29 -57 -84 -86
  10 -55  78 -49  12 -68
  29  61 -19  17 -79 -86
0,0(0 оценок)
Ответ:
46788643
20.02.2021 22:30
#include <iostream>
//Размерность#define n 3#define m 3

//Диапозон#define d_min -8#define d_max 6
void enter_arr(int a[n][m]) { printf("\n >> Введите элементы массива %dx%d\n",n,m); for (int i = 0; i < n; i++) { printf("\n"); for (int j = 0; j < m; j++) { printf(" << a[%d][%d] = ", i+1, j+1); scanf("%d",&a[i][j]); } }}

void print_arr(int a[n][m]) { printf("\n >> Массив %dx%d :", n, m); for (int i = 0; i < n; i++) { printf(" \n >> "); for (int j = 0; j < m; j++)  printf("%d ", a[i][j]); }}
int main(){ setlocale(LC_ALL, "rus"); int a[n][m];
enter_arr(a); print_arr(a);
for (int i = 0; i < n; i++) for (int j = 0; j < m; j++) if ((a[i][j] < d_min) || (a[i][j] > d_max)) a[i][j] *= a[i][j];

print_arr(a);
system("pause>>void"); return 0;}
Ввести двумерный массив аnxm.каждый элемент в массиве чье значение лежит вне диапазона [-8; 6] возве
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота