влад2162
07.05.2021 21:19

Составить программу, которая вычисляет стоимость покупки товаров одного типа с учетом скидок на некоторые группы товаров (группы имеют коды) и скидку 5%, если общая сумма покупки составляет более 100 грн.
Скидки на некоторые группы товаров с кодами от 100 до 500: 100...150 - 2%, 210, 215, 220 - 7%, 230...300 - 9%. Если код группы товаров не относится к указанным, то вывести сообщение об отсутствии скидок. Программа Python

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ученик132312
22.09.2022 14:27

#include <iostream>

int main() {

const int SIZE = 10;

bool isSence = false;

int sum = 0;

int count = 0;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 arr[i] = rand() % 20 - 10; // "рандомно" заполняем массив от -10 до 10

 std::cout << arr[i] << "\t"; // выводим массив в консоль

 if (arr[i] >= 0)

  isSence = true;

}

for (int i = 0; i < SIZE; i++)

{

 if ((isSence) && (arr[i] > 0))

  sum += arr[i]; //sum = sum + arr[i];

  count++;

}

if (isSence)

 std::cout << "\nсреднее арифметическое положительных чисел = " << double(sum) / count << std::endl; // явное приведение типов

else

 std::cout << "\nВ массиве нету положительных чисел или нету нулей и/или отрицательных чисел" << std::endl;

return 0;

}

0,0(0 оценок)
Ответ:
Ыыыап
02.01.2021 03:38
#include < bits/stdc++.h>   using namespace std;   int main(){        int n, m, k, c = 0, c1 = 0;         cin > > n > > m > > k;         c = n + m;         if (c % k == 0)        {                c1 = c / k;         }        else        {                c1 = (c / k) + 1;         }        if (2 * c1 < = m)        {                cout < < c1;         }        else        {                cout < < 0;         }         //cout < < "hello world! " < < endl;         return 0; }//sadasdadasdasdasd
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота