Maruua1
23.05.2020 10:39

Напишите программу которая запрашивает длину и ширину прямоугольника, вычисляет его площадь и длинну диагонали, а также рисует этот прямоугольник с диагональю

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Пан2007
12.12.2020 16:07

Задача 1

program z1;

var n,a,i,k:integer;

begin

write ('Введите количество чисел: ');

read (n);

for i:=1 to n do

begin

write ('Введите число: ');

read (a);

if a = 0 then k:=k+1

end;

writeln('Количество нулей среди чисел: ',k)

end.

Задача 2

program z2;

var n,a,i,m:integer;

begin

write ('Введите количество чисел: ');

read (n);

for i:=1 to n do

begin

write ('Введите число: ');

read (a);

if i = 1 then m:=a;

if a > m then m:=a

end;

writeln('Максимальное число среди чисел: ',m)

end.

или

program z2;

var n,i,m:integer;

a:array[1..100] of integer;

begin

write ('Введите количество чисел (n<=100): ');

read (n);

for i:=1 to n do

begin

write ('Введите число: ');

read (a[i]);

if i = 1 then m:=a[i];

if a[i] > m then m:=a[i]

end;

writeln('Максимальное число среди чисел: ',m)

end.

0,0(0 оценок)
Ответ:
sashamakarova30
12.12.2020 16:07

1.V=24*2=48 байт = 384 бита

2.192 символа на стр- 30720 символов. Мощность алфавита 256 - значит в алфававите 256 знаков. 2 в степени восемь - равно 256.весь алфавит можно закодировать одним байтом (в одном байте - как раз восемь бит, степень двойки. Бит - принимает ДВА значения - 0 и 1 - отсюда основание 2, которое возводим в восемь :) ) на каждый символ текста надо потратить один байт памяти. Итого получаем 30720 БАЙТ. в одном КИЛОБАЙТЕ 1024 байта. Делим 30720 на 1024 получаем 30 КБайт.

3.в 2 раза уменьшился

4

1024000/8=128000 (перевели в байты) 

128000/1024=125кбайт/сек (перевели в килобайты) 

125*5= 625 килобайт

5.

всего используется 12 букв + 10 цифр = 22 символа 

для кодирования 22 вариантов необходимо использовать 5 бит, так как , т.е. 4 бит не хватит (они позволяют кодировать только 16 вариантов), а 5 уже достаточно 

таким образом, на каждый символ нужно 5 бит (минимально возможное количество бит) 

полный номер содержит 6 символов, каждый по 5 бит, 30 бит один номер. 

по условию каждый номер кодируется целым числом байт (в каждом байте – 8 бит), поэтому требуется 5 байт на номер ( ), 4 байтов не хватает, а 5 – минимально возможное количество 

на 32 номеров нужно выделить 160 байтов приблизительно 192байта 

правильный ответ – 160байт...т.к 32*5=160 или приблизетельно 192байта.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота