Vyacheslav009
30.05.2020 22:11

Составить программу, в которой вычисляется приближённое значение бесконечного произведения

Верхняя граница произведения N вводится пользователем

Результат выполнения может выглядеть так:

N = 100 (вводится пользователем)

PR = 2

N

П(1+(1/2)^2n)

n=0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Happymilks
17.07.2021 09:18
Вот на С++:

#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long double ld;
typedef long long lol;
typedef long int  li;#define mp          make_pair
#define F           first
#define S           second
#define sqr(a)      ( (a) * (a) )
#define pb          push_back
#define INF         999999999
#define ret(a)      cout << endl; system("pause"); return(a)
//#define ret(a)      return(a)using namespace std;int main()
{
    ld x;
    cin >> x;
    x = ( 8 / sqrt( x ) ) + sqrt(x);
    cout << x;
    ret(0);
}
0,0(0 оценок)
Ответ:
Регина56797
08.10.2022 01:36
Var a1, b1, c1, a2, b2, c2, p1, p2, s1, s2: real;
begin
  writeln('Введите строны первого треугольника: ');
  read(a1, b1, c1);
  writeln('Введите стороны второго треугольника: ');
  read(a2, b2, c2);
  p1 := (a1 + b1 + c1) / 2;
  p2 := (a2 + b2 + c2) / 2;
  s1 := sqrt(p1 * (p1 - a1) * (p1 - b1) * (p1 - c1));
  s2 := sqrt(p2 * (p2 - a2) * (p2 - b2) * (p2 - c2));
  if (s1 + 1e-3 > s2) and (s1 < s2 + 1e-3) then writeln('Равновеликие')
                                           else writeln('Неравновеликие');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота