Составить программу, которая задает массив А[5, 6] случайным образом из чисел от -10 до 10 , выводит его на экран и находит количество положительных элементов массива
program corablik; uses Graph, Crt; var grDriver: integer; grMode: integer; ErrCode: integer; x,y,y0,a,b: integer;{a,b-переменные для линии моря, чтоб они не зависели от х,у} procedure more(a,b:integer); begin moveto(0,y0); setcolor(blue); for a:=0 to 680 do{слева направо рисуем синусоиду синего чвета} begin b:=y0-round(sin(a*pi/180)*30);{30-коэффициент масштабирования по оси Х, чем больше, тем волна круче} lineto(a,b); end; end; begin grDriver := Detect; InitGraph(grDriver, grMode, '..\BGI'); ErrCode := GraphResult; y0 := 250; if ErrCode = grOk then begin x:=600; while x>=0 do{лучше использовать цикл while, можно менять величину шага, что тоже влияет на скорость и частоту смены картинки} begin cleardevice; more(a,b);{рисуем волну} setcolor(white);{устанавливаем цвет кораблика} y:=y0-40-round(sin(x*pi/180)*30);{движемся по волне} MoveTo(x - 40, y + 20); LineTo(x - 20, y + 40); LineTo(x + 20, y + 40); LineTo(x + 40, y + 20); LineTo(x - 40, y + 20); MoveTo(x + 15, y + 20); LineTo(x + 15, y - 40); LineTo(x - 20, y + 20); LineTo(x + 15, y + 20); delay(100); {нормальная скорость, если модули *.TPL не глючные как у Вас, время должно быть в миллисекундах, а не в каких-нибудь наносекундах} x:=x-2;{шаг движения} end; end else Writeln('Graphics error: ', GraphErrorMsg(ErrCode)); Settextstyle(0,0,3);{устанавливаем стиль шрифта} cleardevice; setcolor(red); OuttextXY(200,240,'Rejs zavershen!');{выводим надпись} readln; CloseGraph; end.
Параграф называется "Понятие как форма мышления " В понятии отражается совокупность существенных признаков отдельного объекта или класса однородных объектов . Анализ, синтез , сравнение , абстрагирование и обобщение являются основными логическими приемами формирования понятий Определение понятие - это перечисление всех существенных признаков объекта (класса однородных объектов ) в связном предложении . Каждый из признаков , входящих в определение , должен быть необходимым , а все вместе - достаточны для установления данного понятия
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку