cuwilayab
09.08.2021 01:39

Написать программу Pascal abc
В шкатулке хранится разноцветный бисер (или бусины). Все бусины имеют одинаковую форму, размер и вес. Бусины могут быть одного из N различных цветов. В шкатулке много бусин каждого цвета.
Требуется определить минимальное число бусин, которые можно не глядя вытащить из шкатулки так, чтобы среди них гарантированно были две бусины одного цвета.
Входные данные
Входной файл INPUT.TXT содержит одно натуральное число N - количество цветов бусин (1 ≤ N ≤ 109).
Выходные данные
В выходной файл OUTPUT.TXT выведите ответ на поставленную задачу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
DFV7
13.10.2020 03:01

var N: integer;

var f: text;  

begin

assign(f,'C:\1\INPUT.TXT');

reset(f);

read(f,N);

close(f);

assign(f,'C:\1\INPUT.TXT');

rewrite(f);

write(f,N+1);

close(f);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота