Рузанка1111
14.11.2020 00:27

С ЗАДАЧЕЙ
Написать программу, которая определяет, является ли целое n, заданное пользователем числом Мерсенна.
4 ≤ n ≤ 2 000 000 000
Число Мерсенна – это натуральное число вида M = 2p – 1, где p – натуральное число число – это натуральное число, которое не делится нацело ни на одно число кроме самого себя и единицы.
Важно:
Так как n = × , при n= m1 × m2, если m1 > , то m2 < . Также при чётном m1 или m2, n будет чётным. Значит для того, чтобы определить, является ли числом, достаточно проверить его делимость на 2 и на нечётные числа на промежутке от 3 до
Примеры:

Число 1023 не является числом Мерсенна.
Число 127 является числом Мерсенна.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Pool6914
01.04.2020 14:04

ответ:1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

uses crt;

var

i,n,k:integer;

a:array[1..100] of integer;

begin

writeln('введите числа последовательности. Окончанием ввода будет число 0');

i:=0;

n:=0;

repeat

i:=i+1;

n:=n+1;

read(a[i]);

write(' ');

until (a[i]=0) or (i>1000);

writeln;

k:=0;

writeln('Последовательность:');

for i:=1 to n-1 do

begin

write('a[',i,']=',a[i],' ');

if ((a[i] mod 2)=0) and ((a[i] mod 7)=0) then

k:=k+1;

end;

writeln('кол-во целых чётных чисел кратных 7 - ',k);

end.

Второй вариант : 1

2

3

4

5

6

7

8

9

10

11

12

13

14

uses crt;

var k,n: integer;

begin

write('vvedite chislo ');

readln(n);

if (n mod 7=0) and (n mod 2=0) then inc(k);

while n<>0 do

     begin

     write('vvedite chislo ');

     readln(n);

     if (n mod 7=0) and (n mod 2=0) then inc(k);

     end;

writeln(k-1);

end.

3 ВАРИАНТ :

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

const

 lim1=30000;

 lim2=1000;

var

 a,kol,res:integer;

begin

 kol:=0;

 res:=0;

 repeat

   repeat

     readln(a);

     if abs(a)>lim1 then

       writeln('Oshibka vvoda. |a|<=',lim1);

   until abs(a)<=lim1;

   if a<>0 then

     begin

       inc(kol);

       if (a mod 2=0) and (a mod 7=0) then

         inc(res);

     end;

 until (a=0) or (kol=lim2);

 write(res);

end.

0,0(0 оценок)
Ответ:
260111092007
01.04.2020 14:04

ответ:1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

uses crt;

var

i,n,k:integer;

a:array[1..100] of integer;

begin

writeln('введите числа последовательности. Окончанием ввода будет число 0');

i:=0;

n:=0;

repeat

i:=i+1;

n:=n+1;

read(a[i]);

write(' ');

until (a[i]=0) or (i>1000);

writeln;

k:=0;

writeln('Последовательность:');

for i:=1 to n-1 do

begin

write('a[',i,']=',a[i],' ');

if ((a[i] mod 2)=0) and ((a[i] mod 7)=0) then

k:=k+1;

end;

writeln('кол-во целых чётных чисел кратных 7 - ',k);

end.

Второй вариант : 1

2

3

4

5

6

7

8

9

10

11

12

13

14

uses crt;

var k,n: integer;

begin

write('vvedite chislo ');

readln(n);

if (n mod 7=0) and (n mod 2=0) then inc(k);

while n<>0 do

     begin

     write('vvedite chislo ');

     readln(n);

     if (n mod 7=0) and (n mod 2=0) then inc(k);

     end;

writeln(k-1);

end.

3 ВАРИАНТ :

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

const

 lim1=30000;

 lim2=1000;

var

 a,kol,res:integer;

begin

 kol:=0;

 res:=0;

 repeat

   repeat

     readln(a);

     if abs(a)>lim1 then

       writeln('Oshibka vvoda. |a|<=',lim1);

   until abs(a)<=lim1;

   if a<>0 then

     begin

       inc(kol);

       if (a mod 2=0) and (a mod 7=0) then

         inc(res);

     end;

 until (a=0) or (kol=lim2);

 write(res);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота