прост1232
28.01.2022 11:16

пожожда
во Программист составил программу нахождения площади и периметра треугольника, однако при запуске она выдает ошибку. Найдите её.

Program SP;
var S, P, r, a, b, c: integer;
begin
writeln ( 'привет, давай найдем площадь и периметр треугольника' );
a:= 15.67;
b:= 3.5;
c:= 9.34;
P:= a+b+c ;
r:= (a+b+c)/2;
S:=sqrt(r*(r-a)*(r-b)*(r-c)) ;
writeln ( 'периметр треугольника равен ',P);
writeln ( 'Площадь треугольника равна ',S);
writeln ( ' Всего доброго!' );
end.

Выберите ответ
1 после begin стоит точка с запятой
2 неправильная форма нахождения периметра
3 тип переменных не соответствует их значениям
4 забыл ввести переменные
во Определите значение переменной а после исполнения данного алгоритма:

a := 5

b := a * 4 + 4

b := b / (a – 1)

a := a * b / 2
впишите ответ
во Что выполняет данная строка программы?
var d, s: real;
1 присваивает переменным тип var
2 описывает переменные d и s вещественного типа
3 описывает переменные d и s целого типа
во Дана программа. Каков будет результат на выходе, если y=25, x=19?
Program razniza;
Var X,Y,Z: integer;
Begin
Write('Введите два числа ');
Readln(X,Y);
Z:=X-Y;
Write(Z);
End.

Запишите число
во Какая команда описывает переменную а целого типа?
1 var a: integer;
2 readln (a)
3 var a: real;
4 var a: readln;
5 begin a;
задание 6
writeln - это оператор ...
1 ввода
2 вывода
3 присваивания
во или readln - это оператор...

Выберите ответ
1 ввода
2 вывода
3 присваивания

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
OFFICIALLL
27.04.2020 12:30

{ Треугольник задан координатами вершин (x1;y1),(x2;y2),(x3;y3).

Найти площадь треугольника (используя формулу Герона) }

uses crt;

var x1,x2,x3,y1,y2,y3,a,b,c,s,p : real;

begin

clrscr;

write('x1=');readln(x1);

write('y1=');readln(y1);

write('x2=');readln(x2);

write('y2=');readln(y2);

write('x3=');readln(x3);

write('y3=');readln(y3);

a:=sqrt(sqr(x1-x2)+sqr(y1-y2));

b:=sqrt(sqr(x2-x3)+sqr(y2-y3));

c:=sqrt(sqr(x3-x1)+sqr(y1-y3));

p:=(a+b+c)/2;

s:=sqrt(p*(p-a)*(p-b)*(p-c));

write('s=',s);

readln;

end.

формула герона!

А так я думаю эти задачки очень даже не сложные, только формулы надо знать!! !

периметр- это сумма всех сторон

например

begin

writteln( 'введите 3 стороны' ) ;

readln(a,b,c);

writeln(' периметр = ',a+b+c);

readln;

end.

Вот и все!! !

Удачи!

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота