leonru1
31.01.2022 13:05

На языке ПАСКАЛЬ
Дано число n. С начала суток минут. Определите, сколько часов и минут будут показывать электронные часы в этот момент. Программа должна вывести два числа: количество часов (от 0 до 23) и количество минут (от 0 до 59). Учтите, что число n может быть больше, чем количество минут в сутках.

Входные данные
Вводится целое число n.

Выходные данные
Выведите ответ на задачу.

Примеры
входные данные
150
выходные данные
2 30
входные данные
1441
выходные данные
0 1

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
2303901
06.05.2023 18:09

#include <iostream>

int main()

{

int A[5];

int i, imax=0, imin=0,s = 0, k = 0;

setlocale(LC_ALL, "Russian");  // Русский язык в консоли

for (i = 0; i < 5; i++)

{

 std::cin >> A[i];

 if (A[i] == 0) k++;

 else if (A[i] > 0) s += A[i];

 if (A[i] > A[imax]) imax = i;

 if (A[i] < A[imin]) imin = i;

}

std::cout << "Максимальный элемент равен " << A[imax] << ", его номер - " << imax+1 << std::endl;

std::cout << "Минимальный элемент равен " << A[imin] << ", его номер - " << imin + 1 << std::endl;

std::cout << "Сумма положительных элементов равна " << s << std::endl;

std::cout << "Количество элементов, равных нулю: " << k << std::endl;

return 0;

}

0,0(0 оценок)
Ответ:

#include <iostream>

int main()

{

int A[5];

int i, imax=0, imin=0,s = 0, k = 0;

setlocale(LC_ALL, "Russian");  // Русский язык в консоли

for (i = 0; i < 5; i++)

{

 std::cin >> A[i];

 if (A[i] == 0) k++;

 else if (A[i] > 0) s += A[i];

 if (A[i] > A[imax]) imax = i;

 if (A[i] < A[imin]) imin = i;

}

std::cout << "Максимальный элемент равен " << A[imax] << ", его номер - " << imax+1 << std::endl;

std::cout << "Минимальный элемент равен " << A[imin] << ", его номер - " << imin + 1 << std::endl;

std::cout << "Сумма положительных элементов равна " << s << std::endl;

std::cout << "Количество элементов, равных нулю: " << k << std::endl;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота