malyxd
21.02.2023 14:44

с задачей,я слишком глуп,необходимо написать программу на языке паскаль

У избушки Бабы Яги каждый год появляется по три ноги, но после того, как ей исполнится 100 лет (т.е. со 101 года)- только по две.

Сколько куриных ножек и пальцев на них(если на одной ноге обычно их вырастает 4) у избушки, которой N лет?(сначала в задаче с возраст избушки, он то и будет переменной N).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
iloveyou27
25.12.2020 12:27

var

  k: integer;

begin

  readln(k);

  if k< 0 then

    writeln('не может такого быть')

  else

    begin

      write('мы нашли в лесу ',k,' гриб');

      if (k mod 100 in [5..19]) then

        writeln('ов')

      else if (k mod 10 in [2..4]) then

        writeln('а')

      else if (k mod 10=1) then

        writeln

      else

        writeln('ов');

    end;

end.

0,0(0 оценок)
Ответ:
austry1337
04.11.2022 02:30

java

import java.util.random;

public class myapp{

  public static void main (string {

    random rand = new random();

    int n = rand.nextint(50);

    int [] arr = new int[n];

    for(int i = 0; i < n; i++) {

      int j = rand.nextint(50);

      arr[i] = j;

    }

    for( int i = 0; i < n; i++) {

      if ( arr[i] % 2 == 0 ) {

        system.out.print(arr[i] + " ");

      }

    }

  }

}

pascal

program myapp;

var

  i, n , j: integer;

  arr: array of integer;

begin

randomize;

n : = random(50);

setlength(arr, n);

for i: = 0 to n do

  begin

    j: = random(50);

    arr[i]: = j;

  end;

for i: = 0 to n do

  begin

    if( arr[i] mod 2 = 0 ) then

      begin

        write(arr[i], ' ');

      end;

  end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота