xfcsfttvd
12.08.2022 20:09

Напишите программу, которая получает натуральные числа a и b (A>B) и выводит все числа в интервале от A до B

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mariakochmar
25.10.2020 14:20
1. Вот так это нужно решать по-современному

// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  Writeln('k=',ArrRandom(15,1,20).Println.Count(x->x>10))
end.

Тестовое решение
4 16 14 9 11 18 17 14 14 15 1 1 9 10 15
k=9

2. А вот так учат решать в школе...

// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
var
  a:array[1..15] of integer;
  i,k:integer;
begin
  Randomize;
  k:=0;
  for i:=1 to 15 do begin
    a[i]:=Random(20)+1;
    Write(a[i],' ');
    if a[i]>10 then k:=k+1
    end;
  Writeln;
  Writeln('k=',k)
end.

Тестовое решение:
18 15 7 6 3 3 10 6 6 15 2 16 16 2 12
k=6
0,0(0 оценок)
Ответ:
mkudrya
15.09.2020 16:01
Var
a: array[1..4, 1..4] of integer;
i, j, x, y, n: integer;
s: string;
begin
for i:=1 to 4 do
for j:=1 to 4 do
read(a[i, j]);
writeln('Введите "столбцы", чтобы поменять столбцы, или "строки", чтобы поменять строки');
readln(s);
writeln('Введите номера столбцов/строк');
readln(x, y);
if s='столбцы' then
for i:=1 to 4 do
begin
n := a[i, x];
a[i, x] := a[i, y];
a[i, y] := n;
end;
if s='строки' then
for i:=1 to 4 do
begin
n := a[x, i];
a[x, i] := a[y, i];
a[y, i] := n;
end;
for i:=1 to 4 do
begin
for j:=1 to 4 do
write(a[i, j], ' ');
writeln;
end;
end.
Вдвумерном массиве по запросу поменять два заданных столбца или две строки? ))
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота