ekaterinakostin
15.09.2021 20:36

Нужна даю 40 болов
{Программа - диалог с компьютером.}
Program P1;
var Name:string;
Age:integer;
begin
write('Укажите Ваше имя: ');
readln(Name);
writeln('Здравствуйте, ',Name);
write('Укажите Ваш возраст: ');
readln(Age);
write('Через два года Вам будет: ',Age+2);
end.

Задание1:
1)Самостоятельно создать такую программу по образцу
2) ответить на во Что будет, если вместо имени ввести цифры?
Что будет, если на во о возрасте ввести букву?

3) Программа-диалог(Написать самостоятельно).
1)С у пользователя, в какой стране он планирует провести отпуск (завести переменную типа string, так как название страны – это слово. Например, Country:string;).
2)С какую сумму денег планируется потратить (завести переменную типа integer, так как сумма денег выражается числом. Например, Summa:integer;).
3)С сколько бонусных имеет клиент (здесь тоже нужна будет числовая переменная. Например, Bonus:integer;).
4)Вывести сообщение: «Страна – такая-то. Стоимость тура – такая-то.»
Стоимость тура можно рассчитать как
Summa–2*Bonus.Или как-нибудь по-другому использовать бонусы, на ваше усмотрение.

4)Рассчитать стоимость тура с учетом бонусных и вывести сообщение на экран.

{Вычислить периметр прямоугольника}
Program P2;
uses crt;
var a,b:integer;
begin
write('Укажите через пробел длины сторон прямоугольника: ');
readln(a,b);
writeln('P=',2*(a+b))
end.
Задание 2:
1)Самостоятельно написать программу, которая вычисляет площадь прямоугольника с заданными длинами сторон.
Задание 3:
Читать §3.2 учебника.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Pinno4ka
20.09.2021 11:59
1. Выразим выражения по правилам языка Pascal:
a) 5 * 2 - 4
Решение:
Умножение имеет более высокий приоритет, чем вычитание. Поэтому, сначала выполним вычисление умножения: 5 * 2 = 10.
Затем, выполним вычитание: 10 - 4 = 6.
Ответ: 6.

б) 7 * х + 2
Решение:
Умножение имеет более высокий приоритет, чем сложение. Поэтому, сначала выполним вычисление умножения: 7 * х = 7х.
Затем, выполним сложение: 7х + 2.
Ответ: 7х + 2.

в) 8 * х - 3 * (х + у)
Решение:
Выполним умножение: 8 * х = 8х и 3 * (х + у) = 3х + 3у.
Затем, выполним вычитание: 8х - (3х + 3у).
Для выполнения операции в скобках, умножение 3 на каждый из элементов внутри скобок:
8х - 3х - 3у = 5х - 3у.
Ответ: 5х - 3у.

г) v^2 * х * у^2 * х * у
Решение:
По правилам алгебры, умножение можно проводить в любом порядке.
Выполним умножение: v^2 * х = v^2х, у^2 * х = у^2х, v^2х * у^2х = (vх * у)^2х.
Ответ: (vх * у)^2х.

2. Переведем запись с языка Pascal в нормальную форму:
f = (3 * x + 4 * y)/(2 * sqr(к) - 4 * t / y)
Решение:
Нормализация выражения подразумевает разделение на более простые составляющие.
Заменим sqr(к) на к^2, чтобы выразить возведение в квадрат в общепринятой форме:
f = (3 * x + 4 * y)/(2 * к^2 - 4 * t / y)
Затем, выполним умножение и деление в числителе и знаменателе:
f = (3 * x + 4 * y)/(2к^2 - (4 * t) / y)
Ответ: f = (3 * x + 4 * y)/(2к^2 - 4t/y).

Таким образом, мы записали выражения по правилам языка Pascal и перевели запись с языка Pascal в нормальную форму.
0,0(0 оценок)
Ответ:
zekisroman
04.05.2020 00:45
1. Достоинства электронных книг:
- Высокая стоимость: это неверное утверждение. Электронные книги обычно стоят дешевле, чем печатные, или даже могут быть бесплатными.
- Изменение размеров шрифта: это верное утверждение. Одним из преимуществ электронных книг является возможность изменения размера шрифта, что делает чтение более комфортным для пользователей с разными потребностями.
- Переходы по гиперссылкам: это верное утверждение. Электронные книги обычно содержат гиперссылки, которые позволяют быстро перемещаться по разным разделам книги или переходить к другим источникам информации.
- Компактность хранения: это верное утверждение. Электронные книги занимают мало места на устройстве хранения (например, на компьютере или смартфоне), поэтому их можно легко собирать в большом количестве без затрат на физическое пространство.
- Возможность озвучивать текст: это верное утверждение. Некоторые электронные книги имеют функцию озвучивания текста, что позволяет пользователю слушать книгу вместо чтения.
- Высокая чувствительность к физическому воздействию: это неверное утверждение. В отличие от печатных книг, электронные книги более устойчивы к физическому воздействию, такому как механические повреждения или загрязнения.

2. Основные функции текстового редактора:
- Строгое соблюдение правописания: это неверное утверждение. Хотя текстовые редакторы обычно имеют функцию проверки правописания, это не является их основной функцией.
- Копирование, перемещение, сортировка текста: это верное утверждение. Одной из основных функций текстового редактора является возможность копирования, перемещения или сортировки текста внутри документа.
- Создание, редактирование, сохранение, печать текстов: это верное утверждение. Текстовый редактор позволяет создавать новые документы, редактировать уже существующие, сохранять их в файлы и печатать текст на бумаге.
- Автоматическая обработка информации, имеющейся в текстовом файле: это верное утверждение. Современные текстовые редакторы могут предоставлять функции автоматической обработки информации в текстовом файле, такие как поиск и замена, подсчет слов или символов и другие операции.

3. Пропущенное звено в ряду "Символ – слово – … – фрагмент текста":
- Абзац: это верное утверждение. Абзац является промежуточным звеном между словом и фрагментом текста. Он представляет собой блок текста, содержащий одну или несколько связанных мыслей или идей, отделенных от остального текста пустыми строками или отступами.

5. Текстовый редактор входит в состав:
- Прикладного программного обеспечения: это верное утверждение. Текстовый редактор является одной из основных программ, входящих в состав прикладного программного обеспечения, которое предназначено для выполнения конкретных задач пользователем (например, создания и редактирования текстовых документов).

6. Названия разделов разных уровней составляют:
- Оглавление: это верное утверждение. Оглавление представляет собой список разделов и подразделов документа вместе с указанием их страниц или номеров, что позволяет пользователю быстро найти нужную информацию или перемещаться по документу.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота