sofa286
29.01.2020 03:55

1.Напишите программу, которая вычисляет среднюю за неделю температуру воздуха. Исходные данные вводятся с датчика случайных величин из промежутка [-30; 35]
2.Дан массив из ста действительных чисел (данные вводятся с датчика случайных величин из промежутка [-20; 50]). Напишите программу подсчёта количества элементов этого массива, имеющих минимальное значение.
3.В классе 34 ученика писали тест по информатике. Напишите программу, подсчитывающую количество двоек, троек, четвёрок и пятёрок, полученных за тест.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
JoyGames14982
25.08.2021 04:07

begin   //начало программы

var nk, nt, ck ,ct, s: integer  // задание переменных типа действительные числа;


writeln('Введите количество карандашей'); //вывести на экран надпись

readln(nk);  // запись ответа пользователя в переменную nk

writeln('Введите количество тетрадей'); //вывод на экран надписи

readln(nt); // запись ответа пользователя

writeln('Введите стоимость 1 карандаша');  // вывод на экран надписи

readln(ck); // запись ответа пользователя в переменную

writeln('Введите стоимость 1 тетради');

readln(ct);

s:=(nk*ck)+(nt*ct); // вычисление стоимости покупки

writeln('Стоимость покупки: ',s);  // вывод стоимости покупки на экран

end.  // конец программы

(ck-стоимость 1 карандаша, ct-стоимость 1 тетради, s-стоимость покупки)

(nk-количество карандашей, nt-количество тетрадей)

0,0(0 оценок)
Ответ:
ddawka
25.08.2021 04:07

Я буду писать часть предложения, а внизу табличку, чтобы понятнее было))

Набрать 9 литров в первую ёмкость.

1. 9 л      2. 0л (пока что) 

Перелить 5 литров во вторую ёмкость.

1.4 л       2. 5л

Из второй ёмкости вылить всю воду

1.4л        2. 0л

И из первой ёмкости перелить во вторую ёмкость оставшиеся 4 литра.

1.0 л      2. 4л

Набрать полную первую ёмкость

1. 9л     2. 4л

И из неё перелить во вторую 1 литр.

1. 8л     2. 5л

Воду из второй емкости вылить

1.8 л     2. 0л

И из 8 литров воды в первой ёмкости перелить во вторую ёмкость 5 литров

1. 3л     2. 5л

Вот и все!!

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота