mar2865
15.06.2022 14:12

Составить программу которая r раз находит m! значение r,m заполняются генератор случайных чисел с аргументом 6

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dbuzoverova
08.06.2020 00:22

Объяснение:

function factorial(n:integer):integer;

var

 i, p:integer;

begin

 p:=1;

 for i:=1 to n do

   p:=p*i;

 factorial:=p;

end;

var

 r, m:integer;

 k:integer;

begin

 randomize;

 r:=random(6);

 writeln('r = ', r);

 for k:=1 to r do begin

   m:=random(6);

   writeln(m, '! = ', factorial(m));

 end;

 readln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота