neketapro
24.02.2020 18:35

Напишите программу, которая находит наибольшее значение среди чисел, записанных в файле в столбик, и выводит результат в другой файл.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katerok23092000
25.11.2022 04:22
Алгоритм решения следующий:

Сначала считывается введенное слово в переменную. Далее, в цикле от начала слова и до его конца проверяется, является ли текущая буква, равной искомой, то есть букве "а". Если такая буква найдена, то выводится её позиция в слове.

А теперь комментарий по каждой из строчек кода.

// Блок объявления переменных
var a:string; 
var i:integer;
// Начало программы
begin
// Ввод слова
writeln('Введите слово');
// Считывание слова
read(a);
// Цикл от 1 до длины считанного слова
for i:=1 to length(a) do begin
// Условие на то, является ли текущая буква заданной
if (a[i]='а') then begin
// Если является, вывод её позиции на экран
writeln('Найдена буква “а”, ее позиция:' , i);
// и прерывание дальнейшего цикла, выход из него
break;
// Завершение блока "if"
end;
// Завершение цикла
end;
// Завершение программы
end.
0,0(0 оценок)
Ответ:
66666666ak
17.10.2020 20:39
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  // №1
  var a:=ArrRandom(15,-50,50); a.Println;
  a.IndexesOf(t->t.IsEven).Select(t->t+1).Println;
  // №2
  var b:=ArrRandom(ReadInteger('n='),0,86); b.Println;
  a.Where(t->t mod 3=0).Sum.Println;
  // №3
  var c:=ReadArrInteger(ReadInteger('m='));
  c.Sum.Println;
  // №4
  var d:=ArrRandom(ReadInteger('n='),-60,60); d.Println;
  d.Where(t->t>0).Sum.Println
end.

Пример
41 37 -10 7 33 -8 49 -1 -14 26 -17 -23 47 -25 7
3 6 9 10
n= 13
0 63 53 71 35 56 34 86 31 15 84 74 35
33
m= 8
13 -12 54 11 47 0 42 100
255
n= 18
52 39 -43 48 -34 -56 -14 28 -51 48 -56 -21 60 -19 -5 -19 43 44
362
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота