али394
06.08.2021 19:11

1. Написать программу нахождения периметра прямоугольника со сторонами а и b.

2. Составьте программу, проверяющую, является ли введенное вами число отрицательным .

3. Написать программу вывода на экран всех двузначных чисел.
ИНФОРМАТИКА 8 КЛАСС

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
шедвер
06.11.2022 00:42

#include <stdio.h>

#include <stdlib.h>

#include <time.h>

int main(){

   int arr[10],even[10], cur = 0, tmp;

   srand(time(0));

   puts("Source array:");

   for (int i = 0; i < 10; i++){   //генерация массива +

       arr[i] = rand() % 30;   //отбор четных элементов

       printf("%d\n", arr[i]);

       if (arr[i] % 2 == 0){

           even[cur] = arr[i];

           cur++;

       }

   }

   for (int i = 0; i < cur; i++)   //сортировка пузырьком по убыванию

       for(int j = 0; j < cur - i - 1; j++)

           if (even[j+1] > even [j]){

               tmp = even[j+1];

               even[j+1] = even[j];

               even[j] = tmp;

           }

   puts("Sorted array:");  //печать сортированного массива

   for (int i = 0; i < cur; i++)

       printf("%d\n", even[i]);

   return 0;

}

Объяснение:

Компилятор gcc 8.2.0

0,0(0 оценок)
Ответ:
tanya2017kazanova
13.10.2020 19:46

4:

var a: array [1..3] of integer;

   i,min,max : integer;

begin

   for i:= 1 to 3 do

   begin

       write('a[',i,'] = ');

       read(a[i]);

       writeln;

   end;

   min:= a[1];

   max:= a[1];

   for i:= 1 to 3 do

   begin

       if a[i] < min then

       begin

           min:= a[i];

       end;

   end;

   for i:= 1 to 3 do

   begin

       if a[i] > max then

       begin

           max:= a[i];

       end;

   end;

   writeln('min = ',min);

   writeln('max = ',max);

end.

5:

var a: array [1..5] of integer;

   i,max : integer;

begin

   for i:= 1 to 5 do

   begin

       write('a[',i,'] = ');

       read(a[i]);

       writeln;

   end;

   max:= a[1];

   for i:= 1 to 3 do

   begin

       if a[i] > max then

       begin

           max:= a[i];

       end;

   end;

   writeln('max = ',max);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота