Timpo
23.08.2021 10:10

по ИНФОРМАТИКЕ Дан массив С, состоящий не более чем из 15 целых чисел.
Написать программу, которая:
1. вводит элементы массива с клавиатуры;
2. находит среднее арифметическое элементов больших 20;
3. находит количество положительных элементов массива;
4. находит минимальный элемент.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
perrybazinga
14.10.2020 06:08

#include <stdio.h>

#include <conio.h>

#include <limits.h>

#define N 15

int main()

{

   int mas[N];

   int i;

   

   for (i = 0; i < N; i++)

   {

       printf("mas[%d] = ", i+1);

       scanf("%d", &mas[i]);

   }

   

   int count = 0, sum = 0, count1 = 0, min = INT_MAX;

   

   for(int i=0; i<N; i++)

   {

       if (mas[i] > 20)

       {

           sum += mas[i];

           count++;

       }

       

       if(mas[i]>=0)

           count1++;

           

       if(mas[i]<min)

           min = mas[i];

   }

   

   sum = sum / count;

   printf("Средне арифметическое элементов больше 20: %d  ", sum);

   printf("\n");

   printf("Положительных: %d  ", count1);

   printf("\n");

   printf("Минимальный: %d  ", min);

   printf("\n");

   

   getch();

   return 0;

}


по ИНФОРМАТИКЕ Дан массив С, состоящий не более чем из 15 целых чисел. Написать программу, которая:
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота