fdnk1
29.02.2020 03:04

Составить программу, которая преобразует введеное с клавиатуры дробное число в денежный формат.например, число 12,5 должно быть преобразовано к виду 12 руб .50 коп а - исходные данныеx,y - результатыtrunc(12,5)=12frac(12,5)=0,50,5*100=50,0trunc(50,0)=50​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
karina211206
10.08.2020 17:58
Var s:string;
n,k,i:integer;
begin
for n:=1 to 2 do
 begin
 writeln('Введите строку ',n,':');
 readln(s);
 k:=0;
 for i:=1 to length(s) do
  begin
  case s[i] of
   '[': k:=k+1;
   ']': k:=k-1;
   end;
  end;
 if k=0 
 then writeln('В строке ',s,' количество [ и ] одинаково')
 else writeln('В строке ',s,' количество [ и ] не одинаково');
 end;
end.

Пример:
Введите строку 1:
c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c
В строке c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c количество [ и ] одинаково
Введите строку 2:
Просто [ пример ]] со [[ скобками
В строке Просто [ пример ]] со [[ скобками количество [ и ] не одинаково
0,0(0 оценок)
Ответ:
florzy
30.01.2023 13:32
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var a:=ReadLines('m17.txt').JoinIntoString.ToIntegers;
  a.Println;
  var b:=a.Select((x,i)->Rec(x,i)).Where(x->x.Item1<0)
    .Select(x->x.Item2).ToArray;
  if b.Count<>2 then
    Writeln('Количество отрицательных элементов не равно двум')
  else begin
    a:=SeqFill(b[0],0).Concat(a.Skip(b[0]).Take(b[1]-b[0]+1))
      .Concat(SeqFill(a.Length-b[1]-1,0)).ToArray;
    a.Println
    end
end.

Тестовое решение:
23 14 7 15 0 13 -6 41 18 13 8 42 27 -11 3 19 10
0 0 0 0 0 0 -6 41 18 13 8 42 27 -11 0 0 0

Файл с исходными данными имеет имя m17.txt. Тестовый файл находится во вложении. Разбивка на строки сделана по 5 значений, но может быть совершенно произвольной. Также нет привязки именно к 17 числам, главное - чтобы отрицательных чисел было ровно два, иначе будет выдано сообщение о их неверном количестве.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота