viginipinigivini
01.12.2022 22:24

Составить программу в паскале даны 2 действительных числа, не равные друг другу. меньшее из них заменить половиной их суммы, а большее- их утроенным произведением. ввод и вывод с комментариями.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vasviktor
08.06.2020 06:12

var a,b,c:real;

begin

   readln(a,b);

   if(a > b) then

       begin

           writeln('a Больше');

           c := a;

           a := a*b*3;

           b := (b+c)/ 2;

           writeln('a = ',a,'   b = ',b);

       end;

if(b > a) then

       begin

           writeln('b Больше');

           c := b;

           b := a*b*3;

           a := (a+c)/ 2;

           writeln('a = ',a,'   b = ',b);

       end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота