nigaic
13.02.2020 07:56

Написать код на pythone с функции filter и объекта stdin. с функции filter и объекта stdin нужно проанализировать поток «маленьких данных», полученных от низкозагруженного сервера сбора статистики. вы должны получить минимальную моду (наиболее часто встречающееся значение) чисел, кратных заданному, для каждой выборки крайне важных данных. если моду найти невозможно, считайте её равной -1. формат ввода в первой строке записано одно натуральное число x. во всех последующих строках записано некоторое количество натуральных чисел, разделённых пробелами. формат вывода для каждой строки требуется вычислить минимальную моду чисел, кратных x. пример 1: ввод: 2 1 2 2 3 3 3 4 4 4 4 вывод: 4 пример 2: ввод: 3 3 6 9 6 3 1 1 1 вывод: 3 -1

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ersultanplay
25.09.2022 23:43

#include <iostream>

int main()

{

   double x1, y1, x2, y2;

   std::cout << "M(x1,y1): ";

   std::cin >> x1 >> y1;

   std::cout << "N(x2,y2): ";

   std::cin >> x2 >> y2;

   if ((x1 - 1) * (x1 - 1) + (y1 + 2) * (y1 + 2) == 4) std::cout << "M(" << x1 << "," << y1 << ")";

   else if ((x2 - 1) * (x2 - 1) + (y2 + 2) * (y2 + 2) == 4) std::cout << "N(" << x2 << "," << y2 << ")";

   else std::cout << "None of the points";

   return 0;

}

0,0(0 оценок)
Ответ:
Аня8785
03.07.2020 17:09

1. Индексом элемента называется…

- Номер элемента в массиве

  2. Массив данных имеет: - Общее имя и один тип.

 

3. Что такое массив?

- Совокупность однотипных данных, хранящихся в последовательных ячейках памяти.

 

4. В записи D[4]=3.5, D обозначает…

- Имя массива.

 

5. Какой ряд данных можно назвать массивом?

- 2.3, 5.7, 10.89.

  6. Найдите правильное описание массива.

- D: array[1..5] of real;

 

7. Для заполнения массива случайными числами мы должны подключить датчик случайных чисел, используя команду…

- Randomize;

 

8. Для заполнения массива путем ввода чисел с клавиатуры мы используем оператор…

- Readln;  

9. Что выполняет следующий фрагмент программы: For i:=1 to N do write (a[ i ], ‘ ’);

- Выводит N значений массива на экран.

 

10. Для подсчета суммы элементов массива в цикле используем следующую запись…

- Sum:=sum+a(i);

 

11. Что выполняет следующий фрагмент программы?

 Min:=a[1]; For i:=1 to N do if a[i]< min then min:=a[i]; Writeln(min);

- Выбирает минимальный элемент массива.

 

12. Для подсчета количества положительных элементов массива будем использовать условие…

- If a[i]>0 then k=:k+1;


13. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение суммы после выполнения следующего фрагмента программы:

sum:=0; for i:=1 to 8 do sum:=sum+r[i]; writeln (sum);

- 25

 

14. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение суммы после выполнения следующего фрагмента программы:

 sum:=0; for i:=1 to 7 do if r[i]>5 sum:=sum+r[i]; writeln (sum);

- 21.

 

15. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]= 4, R[6]=9, R[7]=0, R[8]=8. Определите значение переменной i после выполнения следующего фрагмента программы:

sum:=0; for i:=2 to 7 do if r[i]>5 sum:=sum+r[i]; writeln (sum);

- 9

 

16. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной i после выполнения следующего фрагмента программы: sum:=0; for i:=1 to N do if r[i]>5 sum:=sum+r[i]; writeln (sum);

- нельзя определить.

 

17. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной kol после выполнения следующего фрагмента программы: kol:=0; for i:=1 to 8 do if r[i]>-2 then kol:=kol+1; writeln (kol);

- 6.

 

18. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной kol после выполнения следующего фрагмента программы alphaeus: kol:=0; for i:=1 to 8 do if r[i]<0 then kol:=kol+1; writeln (kol);

- 2

 

19. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]= 4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной max после выполнения следующего фрагмента программы: max:=r[1]; for i:=1 to 8 do if r[i]>max then max:=r[i]; writeln (max);

- 12.

 

20. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной min после выполнения следующего фрагмента программы: min:=r[1]; for i:=1 to 8 do if r[i]< min then min:=r[1]; writeln (min);

- -6
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота