Zarinka952
28.09.2021 12:24

Напишите программу, которая по введенному пользователем натуральному числу n(n < 100) выводит на экран следующую сумму:
1^2+2^2+3^2+⋯+n^2
Для вычисления суммы должен использоваться цикл, нельзя пользоваться готовой формулой.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
amira061
14.10.2020 12:06

python 3:

n = int(input()) # считываем с клавиатуры n

s = 0 # начальное значение суммы

for i in range(1, n + 1): # цикл по i от 1 до n

   s += i * i # увеличиваем s на i * i, то есть i в квадрате

print(s) # выводим s

Можно и короче, например, так:

n = int(input())

s = sum(i * i for i in range(1, n + 1))

print(s)

Или даже в одну строчку:

print(sum(i * i for i in range(1, int(input()) + 1)))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота