timurqwerty
30.04.2022 23:13

1.Запишите по правилам Pascal следующее выражение (помните, что переменные в Pascal могут иметь имена, записанные только на английском языке)
d меньше либо равно 0 или w больше d
2.Определите значение следующего выражения при x=1, y=2. В ответе запишите только одно слово ИСТИНА или ЛОЖЬ
(х>=0) or (y*y < >4)
3.Запишите по правилам Pascal следующее выражение (помните, что переменные в Pascal могут иметь имена, записанные только на английском языке)
х больше 2 и z меньше -3
4.Определите значение следующего выражения при x=1, y=2. В ответе запишите только одно слово ИСТИНА или ЛОЖЬ
(х * y < > 0) and (x > y)
5.Запишите по правилам Pascal следующее выражение (помните, что переменные в Pascal могут иметь имена, записанные только на английском языке). Двойное неравенство как в математике, в Pascal записывать нельзя
(-10 ≤ z <0)
6.Определите значение следующего выражения при x=1, y=2. В ответе запишите только одно слово ИСТИНА или ЛОЖЬ
(not (x*y>0) ) and (y>x)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MaaximKa228
14.07.2022 16:34
В данном случае всё зависит от контекста вопроса.

Если "понимает" процессор, то разговор идёт о прямых командах ему. Самый яркий пример - компилируемые ЯП вроде С или Pascal, где исходный код пользователя переводится в прямые команды ядру системы (уменьшение уровня абстракции).

Если за "завершение строки" воспринимать конец команды (в вышеназванных ЯП это ';'), то компилятор в процессе компиляции (тавтология) разделяет эти строки на отдельные команды, каждая из которых имеет свою последовательность процессорных действий.

Никакие CRLF (конец строки в Windows/DOS) и LF (в *nix-системах) вне строковых литералов (символов в кавычках вроде 'hello') для процессора роли не играет абсолютно.

В принципе, об интерпретируемых ЯП можно сказать то же самое. Для процессора "завершения строки" как такового не существует.

простить, если дал не тот ответ, что требовалось.
0,0(0 оценок)
Ответ:
Rabver
17.02.2022 02:13
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(4,8,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var sa:=a.Rows.SelectMany(x->x);
  Writeln('Положительные элементы:');
  sa.Where(x->x>0).Println;
  Write('Максимальный по модулю элемент: ',sa.Max(x->abs(x)));
end.

Пример
*** Исходная матрица ***
  80   9  -8  32  37  75  43 -72
  71 -79  94 -20 -64 -37 -98  53
  19  84 -63  -4  17   5  38 -86
 -32  56  87 -43  28 -40 -35  24

Положительные элементы:
80 9 32 37 75 43 71 94 53 19 84 17 5 38 56 87 28 24
Максимальный по модулю элемент: 98
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота