yhenik2015
25.02.2020 15:40

Написать программу вывода на экран всех трехзначных чисел, кратных и 6, и 4, и заканчивающихся на цифру 8. программу написать темя с использованием циклов for, while, repeat. !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
10584869678
08.06.2020 15:05

 Var i:integer;

begin

for i:=100 to 999 do if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');

end.

 

{While}

Var i:integer;

begin

 i:=100;

while i<=999 do begin

if( if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' '); inc(i); end;

end.

 

 

 {Repeat}

Var i:integer;

 begin

i:=100; 

repeat

begin

 if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');

inc(i); end; 

until i<1000;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота