Anna977497
03.07.2021 03:19

Написать код программы , который в последовательности натуральных чисел определяет максимальное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dumbass1007
14.10.2020 13:33

program z1;

var a, i, n, max: integer;

begin

max:=0;

write ('Введите количество чисел в последовательности ');

readln (n);

for i:=1 to n do

begin

write ('Введите натуральное число ');

readln (a);

if a > max then max:=a

end;

writeln('Максимальное число в последовательности ',max)

end.

Объяснение:

Т.к. программа будет получать на вход натуральные числа, то первоначальным значением для переменной max можно взять 0.

Он не является натуральным числом, но все натуральные числа больше него.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота