stone8r4
01.08.2022 17:15

Написать программу для вывода на экран всех больших латинских букв в обратном порядке.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gallagersandr
06.01.2020 03:56
1. Основная трудность при чтении египетских иероглифов в том, что большинство египтян не имели понимания древнегреческой системы иероглифов.
2. Египтяне использовали значки-определители для того, чтобы лучше было читать. Значки-определители служили для звучаний слов.
3. Потому что само чтение или писание древнегреческих иероглифов было сложно , так как в то время образования было ужасным.
4. Первым, кому удалось расшифровать египетские иероглифы, был французский учёный, Жан-Франсуа Шампольон(1790-1832). Он составил полный список иероглифов и их греческих эквивалентов, создав тем самым основу для перевода всех египетских иероглифических текстов.
5. Основным носителем информации в египте являлись глиняные таблички, папирусные свитки и наскальные надписи.
6. Стебли растения разрезали на полосы, которые переплетали между собой, прессовали и высушивали на солнце.
7. Хранили в глиняных кувшинах и шкатулках.
0,0(0 оценок)
Ответ:
den222276
08.12.2022 15:07
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <vector>
#include <iostream>
#include <algorithm>
#include <utility>
#include <random>
#include <iterator>
using namespace std;

int main()
{
    mt19937 gen{ random_device()() };
    uniform_int_distribution<> uid(1, 100);
    vector<vector<int>> v2d(3, vector<int>(3));
    int max_i;
    for_each(v2d.begin(), v2d.end(), [&max_i, &uid, &gen](vector<int>& v) {
            generate(v.begin(), v.end(), [&uid, &gen]() { return uid(gen); });
            max_i = max(*max_element(v.begin(), v.end()), max_i);
        });
    cout << endl;
    v2d.erase(remove_if(v2d.begin(), v2d.end(), [&max_i](vector<int>& v) {
        return find(v.begin(), v.end(), max_i) != v.end();
    }), v2d.end());
    for (const auto& i : v2d)
    {
        copy(i.begin(), i.end(), ostream_iterator<int>(cout, " "));
        cout << endl;
    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота