amir1290
06.04.2022 06:00

На PYTHON. Напишите программу, подсчитывающую во введенной строке количество гласных

букв.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Masha36127
25.01.2022 12:10

Оператор mod возвращает остаток от деления. Четное число – такое, остаток от деления которого на 2 равен нулю.

Функция int возвращает целую часть дробного числа. С её можно реализовать mod (\texttt {a mod b} – примерно то же самое, что и \texttt{a - b * int(a / b)}) или сравнить результат умножения на 2 целой части результата деления исходного числа на 2 с исходным числом.

Код:

begin

   var a := ReadInteger();

   writeln(a mod 2 = 0);

   writeln(a - 2 * int(a / 2) = 0);

   writeln(a = 2 * int(a / 2));

end.


Пример ввода:

5

Пример вывода:

False

False

False


Пример ввода:

42

Пример вывода:

True

True

True

0,0(0 оценок)
Ответ:
ulyanatretakova
13.11.2022 16:41

#include <iostream>

#include <cstdlib>

using namespace std;

void Output(void);

char numbers [10] [6] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};

int digit;

int main()  

{  

cout << "Input digit: ";

cin >> digit;

 

switch(digit)

{

 case 0:

  Output();

  break;

 case 1:

  Output();

  break;

 case 2:

  Output();

  break;  

 case 3:

  Output();

  break;

 case 4:

  Output();

  break;

 case 5:

  Output();

  break;

 case 6:

  Output();

  break;

 case 7:

  Output();

  break;

 case 8:

  Output();

  break;

 case 9:

  cout << "No more digits";

  break;

 default:

  cout << "Input error! This is not a digit";

  return 1;

}

return 0;

}

void Output(void)

{

cout << "Next digits are ";

for (int i = digit + 1; i < 10; i++)

 cout << numbers [i] << " ";

}

// К сожалению, выравнивание текста и, если можно так выразиться, табуляция не везде корректно сохраняются, то сдвиги где-то отображаются, где-то нет. Поэтому прилагаю .cpp файл

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота