Erasylzhakanov
13.12.2020 16:32

1)Составьте программу, вычисляющую произведение чисел от 1 до 100. То
есть P = 1 ∙ 2 ∙ 3 ∙ 4 ∙ 5 ∙ ... ∙ 100\
2)Напишите программу, определяющую, сколько четных чисел в интервале [1,
n]. Число n нужно за заранее
Программа на паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
shuraKotokoto
22.09.2022 22:26
Заполнение массива случайными числами:

Var
   A:array[1..10000] of real;
   n,i:integer;
Begin
Randomize;
Write('n = ');
ReadLn(n);
Write('A(',n,'):');
For i:= 1 to n do
    Begin
    A[i]:=random*(2*n+1)-n;
    Write(' ',A[i]:0:1)
    End;
WriteLn;
i:=0;
For n:= 1 to n-1 do
    if (A[n] > 0)and(A[n+1] > 0) then i:=i+1;
WriteLn('k = ',i);
End.

Ввод с клавиатуры, без массива:

Var
   A,A2:real;
   n,k:integer;
Begin
Write('n = ');ReadLn(n);
Read(A);
k:=0;
For n:= 2 to n do
    Begin
    A2:=A;
    Read(A);
    if (A > 0)and(A2 > 0) then k:=k+1;
    End;
WriteLn('k = ',k);
End.
0,0(0 оценок)
Ответ:
Емсимася
22.05.2023 20:51
var 
a, b, c, d: real;

procedure Plo(s: string; x, y, z: real);
var 
sq: real;
begin 
if ((y + z - x) > 0) and ((x + z - y) > 0) and ((x + y - z) > 0) then 
begin   
sq := 0.25 * (sqrt((x + y + z) * (y + z - x) * (x + z - y) * (x + y - z)));   
writeln('Площадь треугольника со сторонами ', s, ' = ', sq:0:3); 
end else writeln('Треугольник со сторонами ', s, ' не существует');
end;

begin 
write('a=');readln(a); 
write('b=');readln(b); 
write('c=');readln(c); 
write('d=');readln(d); 
Plo('a,b,c', a, b, c); 
Plo('a,b,d', a, b, d); 
Plo('a,c,d', a, c, d); 
Plo('b,c,d', b, c, d);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота