kateshopina0703
28.03.2020 03:24

Заполните массив с клавиатуры целыми числами и найдите индексы тех элементов, модуль которых меньше заданного числа А (А вводить с клавиатуры).

Входные данные:

в первой строке целое число n (0 < n ≤ 100) — кол-во элементов в массиве и число целое А (по модулю не превосходит 32000). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) — значения элементов массива.

Выходные данные:

индексы тех элементов, модуль которых меньше заданного числа А разделенные пробелом. Если элементов с указанными свойствами не оказалось, то выведите число «0».

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ukharitonova
28.01.2020 17:51

1:Те́кстовый реда́ктор — самостоятельная компьютерная программа или компонент программного комплекса, предназначенная для создания и изменения текстовых данных в общем и текстовых файлов, в частности. Текстовые редакторы предназначены для работы с текстовыми файлами в интерактивном режи

2 Текстовый редактор — это программа, используемая специально для ввода и редактирования текстовых данных.

3 Word (дальше хз)

4 Документ – это материальный носитель, содержащий какую-либо информацию. Обычно подразумевается, что она выражена в текстовом виде, хотя существуют фотодокументы, видео- и аудио-. От обычного текста он отличается наличием реквизитов.

5 принтер

6 я не поняла этот вопрос. объясни его в комментариях и я отвечу

0,0(0 оценок)
Ответ:
budarnyypetr
04.09.2020 03:16
//Pascal ABC.NET v3.1 сборка 1172

Var
 f,s:text;
 st,sp:string;
 i:integer;
 c:char;
begin
 assign(s,'text1.txt');
 reset(s);
 while not Eof(s) do
 begin;
 readln(s,sp);
 st:=st+sp+chr(10)+chr(13);
 end;
 close(s);
 for i:=1 to length(st) div 2 do
  begin
   c:=st[i];
   st[i]:=st[length(st)-i+1];
   st[length(st)-i+1]:=c;
  end;
 assign(f,'text.txt');
 rewrite(f);
 write(f,st);
 close(f);
end.

Текст в файле text1.txt:

Simple text
1And another simple text
2New text

Текст в файле text.txt:
txet weN2
txet elpmis rehtona dnA1
txet elpmiS
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота