Djdjdjdjdjje
30.03.2022 22:52

Составить программу которая по заданным измерениям: длина, высота и ширина. Вычисляет объем параллелепипеда.
задача решается в 4 этапа. В блок-схеме должно быть понятно где прямоугольник, где параллелограмм

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
аграил9
07.12.2021 15:43

Программа:

program dividers;

var x, i, p: integer;

   y: array of integer;

function dividersOf(n: integer; includeNegative: boolean := false):array of integer;

var a: array of integer;

   i, k: integer;

begin

 k:= 1;

 if(n<0) then n:= n*(-1);

 for i:= 1 to n

   do if(n mod i = 0)

        then begin

               SetLength(a, k);

               a[a.Length-1]:= i;

               k:= k+1;

             end;

 if(includeNegative)

   then a:= a.Select(x -> x*(-1)).Sorted.ToArray+a;

 dividersOf:= a;

end;

begin

 readln(x);

 y:= dividersOf(x, true);

 p:= y.Length-2;

 i:= 0;

 writeln('Делители числа ', x, ':');

 repeat

   write(y[i], ', ');

   i:= i+1;

 until i=p;

 write(y[p+1], '.');

end.

0,0(0 оценок)
Ответ:
brzruchkovika
07.12.2021 15:43

Программа:

program dividers;

var x, i, p: integer;

   y: array of integer;

function dividersOf(n: integer; includeNegative: boolean := false):array of integer;

var a: array of integer;

   i, k: integer;

begin

 k:= 1;

 if(n<0) then n:= n*(-1);

 for i:= 1 to n

   do if(n mod i = 0)

        then begin

               SetLength(a, k);

               a[a.Length-1]:= i;

               k:= k+1;

             end;

 if(includeNegative)

   then a:= a.Select(x -> x*(-1)).Sorted.ToArray+a;

 dividersOf:= a;

end;

begin

 readln(x);

 y:= dividersOf(x, true);

 p:= y.Length-2;

 i:= 0;

 writeln('Делители числа ', x, ':');

 repeat

   write(y[i], ', ');

   i:= i+1;

 until i=p;

 write(y[p+1], '.');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота