tanyaG0612
28.05.2023 12:39

Склавиатуры вводится трехзначное число. составьте программу выводящую сумму его чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
arekhvanova
24.05.2020 07:39

var
  a, s: integer; // целочисленный тип данных

begin
writeln('Введите число:');
  readln(a); // вводим число (можно больше трех знаков)
  while a <> 0 do  // пока остались цифры в числе выполнять...
  begin
    s := s + (a mod 10); // Отбираем последнюю цифру числа и прибавляем к сумме
    a := a div 10; // Стираем последнюю цифру числа
  end;
  writeln('Сумма цифр = ', s) // выводим результат
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота