Софамимими
03.05.2020 05:18

1.Напишите программу,в которой вычисляется диаметр круга по заданной площади круга.
2.Для двух произвольных вещественных чисел вычислить их разность,если их первое число больше второго,иначе найти их произведение. Напишите программу для этого алгоритма.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
leon7771
13.08.2020 11:27
Program  Ilgiz98;
var
  i: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Программа находит 4-значные числа, которые делятся на 27');
  writeln('Список таких чисел:');
  for i:=1000 to 9999 do
    if (i mod 27)=0 then writeln(i);
end.

Program  Ilgiz98;
var
  mass: array [1..20] of integer;
  i, k, n: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Среди элементов массива программа находит числа, которые больше заданного числа N и одновременно кратны 5');
  write('Введите число N ');  readln (n);
  writeln('*** Вычисляю... ***');
  k:=0;
  writeln('Массив чисел:');
  for i:=1 to 20 do
    begin
     mass[i]:=random(1000)-500;
     writeln(mass[i]);
     if (mass[i]>n) and ((mass[i] mod 5)=0) then k:=k+1;
  end;
  writeln();
  writeln('Всего найдено ',k,' таких чисел');
end.
0,0(0 оценок)
Ответ:
murrtinez
13.08.2020 11:27
В первой задаче находятся все 4-значные числа, а не только симметричные.
Паскаль АВС.

Program  Ilgiz98;
var
  i: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Программа находит 4-значные числа, которые делятся на 27');
  writeln('Список таких чисел:');
  for i:=1000 to 9999 do
    if (i mod 27)=0 then writeln(i);
end.

Program  Ilgiz98;
var
  mass: array [1..20] of integer;
  i, k, n: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Среди элементов массива программа находит числа, которые больше заданного числа N и одновременно кратны 5');
  write('Введите число N ');  readln (n);
  writeln('*** Вычисляю... ***');
  k:=0;
  writeln('Массив чисел:');
  for i:=1 to 20 do
    begin
     mass[i]:=random(1000)-500;
     writeln(mass[i]);
     if (mass[i]>n) and ((mass[i] mod 5)=0) then k:=k+1;
  end;
  writeln();
  writeln('Всего найдено ',k,' таких чисел');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота