teXerStas
08.09.2022 16:55

составить программу для Pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
karinkacommelЛіза
15.12.2020 21:07
1) var a,b,x:real;
begin
write ('введите числа а и b: '); readln(a,b);
x:=-b/a;
writeln('x= ',x);
end.
2) var r1,r2,s:real;
begin
write ('введите размеры внешнего и внутреннего радиусов: '); read(r1,r2);
s:=pi*r1*r1-pi*r2*r2;
write ('Площадь кольца = ',s);
end.
3) var a,b,c,s,p:real;
begin
write ('введите длины катетов: '); read(a,b);
s:=a*b/2;
c:=sqrt(a*a+b*b);
p:=a+b+c;
write ('Площадь треугольника = ',s);
write ('Периметр треугольника = ',p);
end.
4)  var a,b,sr:real;
begin
write ('введите числа а и b: '); readln(a,b);
sr:=(abs(a)+abs(b))/2;
writeln('среднее арифметическое модулей = ',sr );
end.

5) var x1,y1,x2,y2,r:real;
begin
write ('введите координаты точек: '); readln(x1,y1,x2,y2 );
r:=sqrt ( sqr(x2-x1)+sqr (y2-y1));
writeln('расстояние = ',r );
end.
6)  var a,b,h, s, p:real;
begin
write ('введите длины оснований и высоту трапеции: '); readln(a,b,h);
s:=(a+b)*h/2;
p:=a+b+h+sqrt (sqr(abs(a-b))+h*h);
write ('Площадь трапеции = ',s);
write ('Периметр трапеции= ',p);
end.
7) var a,e,d,s, p:integer;
begin
write ('введите трехзначное число: '); readln(a);
e:=a mod 10; s:=a div 100;
d:= (a div 10) mod 10; p:=e*d*s;
write ('разность между трехзначным числом и его произведением = ',a-p);
end.
 к твоему комментарию 
var x,s,m,c: integer;
begin
write('введите количество секунд: ');readln(x);
c:=x div 3600;
m:= (x mod 3600) div 60;
s:=(x mod 3600) mod 60;
часов ',m,' минут ', s,' секунд ');
end.
0,0(0 оценок)
Ответ:
egor911777
05.08.2022 04:18
Type
  Frac = record
    P: integer;
    Q: 1..32767
  end;

function gcd(a: integer; b: integer): integer;
{Нахождение НОД}
var
  i: integer;
begin
  while b <> 0 do
  begin
    a := a mod b;
    i := b; b := a; a := i
  end;
  result := a
end;

function RedFrac(a: Frac): Frac;
{Сокращение дроби}
var
  igcd: integer;
  r: Frac;
begin
  igcd := gcd(a.P, a.Q);
  r.P := a.P div igcd;
  r.Q := a.Q div igcd;
  RedFrac := r
end;

function Add(a, b: Frac): Frac;
{Сложение дробей}
var
  r: Frac;
begin
  r.P := a.P * b.Q + b.P * a.Q;
  r.Q := a.Q * b.Q;
  Add := RedFrac(r)
end;

function Mult(a, b: Frac): Frac;
{Умножение дробей}
var
  r: Frac;
begin
  r.P := a.P * b.P;
  r.Q := a.Q * b.Q;
  Mult := RedFrac(r)
end;

var
  m, n, k: Frac;

begin
  m.P := 4; m.Q := 15; {4/15}
  n.P := 9; n.Q := 25; {9/25}
  k := Add(m, n);
  Writeln(k.P, '/', k.Q);
  k := Mult(m, n);
  Writeln(k.P, '/', k.Q);
end.

Результат выполнения программы:
47/75
12/125
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота