Lala090
30.06.2020 03:34

Дан фрагмент программы. Определите значение S

Фрагмент:

S:=0

for i =1 to 6 do

S:=S+3; writeln('S='S)
На картинке 5 во

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
LetMaria
21.04.2022 11:22
Const
  Blanks = [' '];

function PosBlank(s: string; pn, pk: integer): integer;
{
  Ищет в строке s в позициях от pn до pk пробельный символ.
  Возвращает его позицию в строке или ноль, если таковой символ не найден.
  Использует подмножество пробельных символов Blanks, что позволяет определять
  произвольный набор пробельных символов (например, табуляцию и т.д.)
}
var
  p: integer;
  flag: boolean;

begin
  p := pn;
  flag := true;
  while flag and (p <= pk) do
  begin
    if s[p] in Blanks then flag := false
    else p := p + 1
  end;
  if p > pk then PosBlank := 0
  else PosBlank := p
end;

function PosNonBlank(s: string; pn, pk: integer): integer;
{
  Ищет в строке s в позициях от pn до pk непробельный символ.
  Возвращает его позицию в строке или ноль, если таковой символ не найден.
  Использует подмножество пробельных символов Blanks, что позволяет определять
  произвольный набор пробельных символов (например, табуляцию и т.д.)
}
var
  p: integer;
  flag: boolean;

begin
  p := pn;
  flag:=true;
  while flag and (p <= pk) do
  begin
    if s[p] in Blanks then p := p + 1
    else flag := false
  end;
  if p > pk then PosNonBlank := 0
  else PosNonBlank := p
end;

var
  s: string;
  i, l, k: integer;

begin
  Write('Введите строку: ');
  Readln(s);
  l := Length(s);
  k := 0;
  i := PosNonBlank(s, 1, l);
  while (i>0) and (i <= l) do
  begin
    k := k + 1;
    i := PosBlank(s, i + 1, l);
    if i = 0 then i := l + 1
    else i := PosNonBlank(s, i + 1, l)
  end;
  Writeln('Количество слов в строке равно ', k)
end.
0,0(0 оценок)
Ответ:
fgrtyrrrrty
08.11.2021 02:45
Диспетчер принимает заказ на такси. 
Принимает звуковую информацию, содержащую адрес подачи такси
Время 
и Адрес назначения.
Правило:
В соответствии с полученной информацией производит поиск по базе свободных таксистов и производит расчет стоимость по заданной формуле. 
Затем передает адреса и время таксисту а стоимость и номер машины клиенту.

Бабушка просит внучку включить на телевизоре какую-нибудь передачу про здоровье.

Получена звуковая информация, содержащая сообщение с задачей - переключать каналы, пока не встретится передача, соответствующая критерию - передача про здоровье.

Правило: 
переключать каналы, пока не встретится передача, соответствующая критерию - передача про здоровье.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота