Лидуня270516
14.03.2020 00:24

ПАСКАЛЬ Написать программу, которая бы по введенному номеру времени года (1 - зима, 2 – весна, 3 – лето, 4 – осень) выдавала соответствующие этому времени года месяцы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alyonavasnecova34
08.03.2022 19:27

В чём ошибка

Ошибка была в том, что циклы выполнялись бесконечно т.к. их условие было всегда истинно. Исправить ошибку можно вычитанием из сдачи значения купюры.

Правильный вариант программы:

program a_4;

var s, k500, k100, k50, k10, k5, k1: integer;

begin

write ('А сколько у вас сдачи? ');

write ('Введите >> ');

readln (s);

while s>=500 do

begin

k500:= k500+1;

s:= s-500;

end;

while s>=100 do

begin

k100:=k100+1;

s:= s-100;

end;

while s>=50 do

begin

k50:=k50+1;

s:= s-50;

end;

while s>=10 do

begin

k10:= k10+1;

s:= s-10;

end;

while s>=5 do

begin  

k5:= k5+1;

s:= s-5;

end;

while s>= 1 do

begin  

k1:= k1+1;

s:= s-1;

end;

writeln ('Итак, вот ваша сдача');

writeln ('Купюр номиналом 500 ', k500);

writeln ('Купюр номиналом 100 ', k100);

writeln ('Купюр номиналом 50 ', k50);

writeln ('Монет номиналом 10 ', k10);

writeln ('Монет номиналом 5 ', k5);

writeln ('Монет номиналом 1 ', k1);

end.

Выполнено в PascalABC.NET

0,0(0 оценок)
Ответ:
Василий300
07.12.2022 16:27

1) ACI, PCY, SCCU, SATA. Каждая шина отвечает за свои устройства, поэтому их так много.

2) Характеристика шины: разрядность потока шины от 32 до 64, скорость передачи данных от 550 мб до 2 ГБ, температура от 20 до 30 градусов.

3) Жёсткий диск(ACI), клавиатура(USB), колонки(PCI), мышь(USB).

4) Их всего 4 вида: SATA, ATA-E, MicroUSB, FSI.

5) На сегодняшний день существует два современных интерфейса, это SQL и SATA. Они используются оба, потому что для каждого интерфейса нужны свои системные шины, к которым соответственно, подключаются контроллеры.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота