skskanshhd
13.09.2021 18:05

РЕБЯТА, УМОЛЯЮ НУЖНО ОЧЕНЬ ОЧЕНЬ Напишите программу, которая в последовательности натуральных чисел определяет сумму всех

чисел, кратных 3 и оканчивающихся на 9. Программа получает на вход натуральные числа, количество

введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания

ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не

превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 3 и

оканчивающихся на 9.

Пример работы программы:

Входные данные Выходные данные

16

29

56

9

39

0

48​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
LilPeepRip11
10.11.2022 02:13

bool ok1(int a, int b, int c){

  return (a+b > c && a+c > b && b+c > a) && min(a,min(b,c)) > 0;

}

bool ok2(int a, int b, int c){

  return ok1(a,b,c) && (a == b || a == c || b == c);

}

signed main(){

  const int n = 3, m = 7;

  int arr[n][m];

  for(int i = 0; i < n; i++)

      for(int j = 0; j < m; j++)

          cin >> arr[i][j];

  vector<int> ans;

  for(int j = 0; j < m; j++)

      if(ok2(arr[0][j],arr[1][j],arr[2][j]))

          ans.push_back(j+1);

  cout << ans.size() << "\n";

  for(auto i: ans)

      cout << i << " ";

}

Подробнее - на -

Объяснение:

0,0(0 оценок)
Ответ:
dreakalex
10.07.2021 20:33

ответ Объяснение:

Будем считать, что вершины четырехугольника пронумерованы, за каждой закреплен постоянный номер. Тогда задача сводится к подсчету числа разных расположения 4 букв на 4 местах (вершинах).

Для решения данной задачи воспользуемся формулой из комбинаторики, которая определяет число перестановок.

P_{n} = n * (n-1)*(n-2)...3*2*1=n!

Из формулы следует, что количество которыми можно расположить 4 буквы на 4 вершинах:

P_{4} =4! = 4 * 3 * 2 * 1 = 24

Число которыми 4 буквы можно разместить на 4 вершинах равно 24.

*4! - факториал 4. Факториалом числа 4 называют произведение всех натуральных чисел, меньше или равных 4.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота