rotaru1930
24.07.2020 12:28

пожежуто
1. Создать программу, которая, за сторону квадрата, выдает, чему равен его периметр и площадь.
2. Создать программу, которая, за целое двухзначное число, выдает, чему равна сумма и произведение цифр этого числа.
Паскаль.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
LenysikRESHAETVSE
14.10.2020 21:11

Первая программа:

program p1;

var

a,p,s : integer;

begin

write('Введите сторону квадрата:');

readln(a);

p := a * 4;

s := a * a;

writeln('Периметр квадрата = ', p);

writeln('Площадь квадрата = ', s);

readln;

end.

Вторая программа:

program p2;

var

a,p,s,pow : integer;

begin

write('Введите число: ');

readln(a);

p := a mod 10;

s := (a div 10) mod 10;

pow := p * s;

writeln('Произведение цифр числа: ', pow);

readln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота