veronamut02
29.06.2022 07:35

Запрограммировать решение задач на языке Паскаль.
1) Программа предлагает вычислить выражение 12*6 - 13*3 и ввести ответ с клавиатуры. Если ответ верен, то вывести на экран фразу "Правильно!", иначе - вывести "Ошибка в расчётах!" 2) Программа запрашивает возраст. Если введён воздаст до 14 лет, то программа выводит "Вы ещё не получили паспорт!, иначе - программа выводит "Пасторт вами получен!". 3*) Составьте программу "Покупка". В магазине продают три вида мороженого: Эскимо по цене 50 рублей, фруктовый лёд по цене 30 рублей и пломбир по цене 48 рублей. Программа запращивает "Какое мороженое хотите купить?". Пользователь вводит название сорта мороженого. В ответ на экран выводится стоимость мороженого.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dsg189g
14.10.2020 21:20

Задача 1)

var a: real;

begin

 writeln('Вычислите выражение 12*6 - 13*3');

 readln(a);

 if a=33 then writeln('Правильно') else writeln('Ошибка в расчётах');

end.

Задача 2)

var a: real;

begin

 writeln('Сколько вам лет?');

 readln(a);

 if a<14 then writeln('Вы ещё не получили паспорт!') else writeln('Паспорт вами получен!');

end.

Задача 3)

program pocupka;

var a: string;

begin

 writeln('Какое мороженное вы хотите купить эскимо, фруктовый лёд или пломбир?');

 readln(a);

 if a='эскимо' then writeln('50 рублей');

 if a='фруктовый лёд' then writeln('30 рублей');

 if a='пломбир' then writeln('48 рублей');

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота