anashakirova09
30.06.2020 13:44

Ниже записана программа. Чему будет равно значение х после выполнения программы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nazarushka
06.11.2021 04:57

1) 20₁₀ = 10100₂

2) 68₁₀ = 1000100₂

3) 400₁₀ = 110010000₂

4) 257₁₀ = 100000001₂

5) 2010₁₀ = 11111011010₂

Объяснение:

1) 20₁₀ = n₂

20 mod 2 = 0

10 mod 2 = 0

5 mod 2 = 1

2 mod 2 = 0

1 mod 2 = 1

Остаток от деления записываем в обратном порядке и получаем число: 10100₂

2) 68₁₀ = n₂

68 mod 2 = 0

34 mod 2 = 0

17 mod 2 = 1

8 mod 2 = 0

4 mod 2 = 0

2 mod 2 = 0

1 mod 2 = 1

Остаток от деления записываем в обратном порядке и получаем число: 1000100₂

3) 400₁₀ = n₂

400 mod 2 = 0

200 mod 2 = 0

100 mod 2 = 0

50 mod 2 = 0

25 mod 2 = 1

12 mod 2 = 0

6 mod 2 = 0

3 mod 2 = 1

1 mod 2 = 1

Остаток от деления записываем в обратном порядке и получаем число: 110010000₂

4) 257₁₀ = n₂

257 mod 2 = 1

128 mod 2 = 0

64 mod 2 = 0

32 mod 2 = 0

16 mod 2 = 0

8 mpod 2 = 0

4 mod 2 = 0

2 mod 2 = 0

1 mod 2 = 1

Остаток от деления записываем в обратном порядке и получаем число: 100000001₂

5) 2010₁₀ = n₂

2010 mod 2 = 0

1005 mod 2 = 1

502 mod 2 = 0

251 mod 2 = 1

125 mod 2 = 1

62 mod 2 = 0

31 mod 2 = 1

15 mod 2 = 1

7 mod 2 = 1

3 mod 2 = 1

1 mod 2 = 1

Остаток от деления записываем в обратном порядке и получаем число: 11111011010₂

0,0(0 оценок)
Ответ:
damama
21.05.2023 06:02
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  if s<>s.MatchValue('[01]+') then Write('не ');
  Writeln('двоичное число')
end.

Пример
010101111011
двоичное число

begin
  var s:=ReadlnString;
  if s<>s.MatchValue('[\+-]?\d+.\d+') then Write('не ');
  Writeln('дробное число')
end.

Пример
12.54
дробное число

begin
  var s:=ReadlnString;
  s.Matches('\s([\+-]?\d{2})\s').Select(t->Trim(t.Value)).Println;
end.

Пример
123.3 15 -11.7 +21 23.2 51 9 182
15 +21 51
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота