7547854
25.03.2022 00:39

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F.

procedure F(n: integer);

begin write(n);

if n > 2 then begin F(n − 1);

F(n − 2);

F(n − 3)

end

end;

Что выведет программа при вызове F(4)? В ответе запишите последовательность выведенных цифр слитно (без пробелов).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
neumnaya4044
20.03.2021 19:43
Я не спец по паскалю но вот на с++ ,думаю всё понятно будет

#include <bits/stdc++.h>
using namespace std;

int main() {
  vector <int> s;
 int i,sred,cis,sum=0;
 while(cin>>cis){
     s.push_back(cis);
 }
 for(i=0;i<s.size();i++){
     sum+=s[i];
 }
 sred=sum/s.size();
 cout<<sred<<endl;
    return 0;
}
Что мы делаем ,сейчас скажу.Сначала мы через while добавляем элементы в массив vector , затем находим сумму элементов массива . И чтобы найти ихнее среднее арифметическую мы делим сумму на количество элементов массива.
0,0(0 оценок)
Ответ:
eraly2
20.03.2021 19:43

var a,b:integer;


c,d:real;


begin


a:=random(50); // Если нужно вводить своё число, то тогда "a:= *заданное число*" или, иначе, readln(a) "


writeln('Число "a" приняло значение ', a); // Если будет один из двух показанных выше, то эта строка не является обязательной.


b:=random(100); // Если нужно вводить своё число, то тогда "b:= *заданное число*" или, иначе, readln(b) "


writeln('Число "b" приняло значение ', b); // Если будет один из двух выше, то эта строка не является обязательной.


c:=((a+b)/2);


writeln('Среднее арифметическое данных двух чисел ', c);


d:=(sqrt(abs(a*b)));


writeln('Среднее геометрическое данных чисел ', d);


end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота